Stop exporting the skia symbols from xul.dll

RESOLVED FIXED in mozilla30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Trunk
mozilla30
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Currently we're exporting around 3000 skia symbols from xul.dll which is a waste of disk space and just bloats xul.dll.

One problem is that configure.in defines both SKIA_DLL and GR_DLL.  This was added in bug 849207, and it seems like the define should have gone inside the Makefile.in then.  Another issue is the {SKIA,GR}_IMPLEMNETATION defines in the moz.build.
Attachment #8384350 - Flags: review?(jmuizelaar)
Duplicate of this bug: 978702
Attachment #8384350 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/a651dd50dea2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.