Closed Bug 978702 Opened 8 years ago Closed 8 years ago

Don't define SKIA_DLL.

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 978626

People

(Reporter: jacek, Assigned: jacek)

References

Details

SKIA_DLL means that dllimport/dllexport attributes will be used for skia APIs. Now that skia is in xul.dll, we shouldn't use those.

This probably causes skia APIs to be exported from xul.dll. Also gcc/binutils are more sensitive to those attributes, so linking on mingw fails without the fix.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 978626
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.