Closed Bug 978739 Opened 6 years ago Closed 6 years ago

After rebooting users are not able to delete/open bookmarks from homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 verified, b2g-v1.3T verified, b2g-v1.4 verified)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- verified
b2g-v1.3T --- verified
b2g-v1.4 --- verified

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1) Create a bookmark, e.g. http://www.mozilla.es
2) Reboot device
3) Delete the bookmark created in the previous session

Expected result:

The bookmark is deleted from grid

Result:

The bookmark is not deleted from grid
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
blocking-b2g: --- → 1.3?
Summary: After rebooting users are not able to delete bookmarks from homescreen → After rebooting users are not able to delete/open bookmarks from homescreen
Attached file Patch v1
Attachment #8384571 - Flags: review?(21)
Depends on: 976955
Keywords: regression
Depends on: 975834
No longer depends on: 976955
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/795b81121e9239e60d44024a89da934fa7be1798
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.3? → 1.3+
Target Milestone: --- → 1.4 S3 (14mar)
Comment on attachment 8384571 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 975834 
[User impact] if declined: users are not able to open/delete bookmarks after rebooting the device
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]:
Attachment #8384571 - Flags: approval-gaia-v1.3?(fabrice)
Keywords: verifyme
Attachment #8384571 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
v1.3: 242e477761643a440e6b244d291fb9d0ce204993
Verified as fixed v1.3. This issue does NOT reproduce on the latest v1.3 Buri build:

3/25 Environmental Variables:
Device: Buri 1.3 MOZ RIL
BuildID: 20140325004002
Gaia: b789780c53adaac199787f51615375f721edfef4
Gecko: 37917eb0dfeb
Version: 28.0
Firmware Version: V1.2-device.cfg

Verified as fixed v1.4. This issue does NOT reproduce on the latest v1.4 Buri build:

3/25 Environmental Variables:
Device: Buri 1.4 MOZ RIL
BuildID: 20140325000201
Gaia: a2a88d0638594a6510f878d2c5e99a6ead7520ad
Gecko: 67bdb575d833
Version: 30.0a2
Firmware Version: V1.2-device.cfg

-

1) I am currently unable to verify this issue on the v1.3T Branch, leaving Verifyme keyword.

2) Changing bug status to verified as this was tested against master v1.4, comment #2
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
Verified issue on latest 1.3T build. Following STR from Comment 0, bookmark is deleted from grid. 

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140530014002
Gaia: e68858693b71d917c9c5ee7e215f7ceea04635f7
Gecko: 1945abae19ff
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
You need to log in before you can comment on or make changes to this bug.