Closed Bug 978767 Opened 6 years ago Closed 6 years ago

Hovering over the zoom controls and cut/copy/paste in the menu on Linux makes the panel layout jump

Categories

(Firefox :: Theme, defect)

30 Branch
x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: phlsa, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(3 files, 3 obsolete files)

Attached video linux panel jump.mov
When moving the mouse over one of the wide controls in the menu panel, that item shrinks by about 1px in height, making all the other items in the panel jump around as well.
Keywords: regression
Bumping the priority, as this is very visible in the default setup.
Whiteboard: [Australis:P4] → [Australis:P3]
I'm going to see if I can knock this out today.
Assignee: nobody → mconley
So it seems this is coming from the fractional margins being added / removed to the combined item separators on hover.
Comment on attachment 8386187 [details] [diff] [review]
Patch v1

So this breaks OS X in a similar fashion.

Ugh.
Attachment #8386187 - Flags: review?(mdeboer)
Attached patch Patch v1.1 (obsolete) — Splinter Review
Attachment #8386187 - Attachment is obsolete: true
Comment on attachment 8386251 [details] [diff] [review]
Patch v1.1

Review of attachment 8386251 [details] [diff] [review]:
-----------------------------------------------------------------

Ouch, but works! Can you land this with a comment above it explaining a bit _why_ we're doing this?
Attachment #8386251 - Flags: review?(mdeboer) → review+
Attached patch Patch v1.2 (r+'d by mikedeboer) (obsolete) — Splinter Review
Added comment. Thanks Mike!
Attachment #8386251 - Attachment is obsolete: true
Attachment #8386322 - Flags: review+
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6dd7b0359a89
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
This patch is wrong and won't reliably fix this bug, depending on the font size.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch patchSplinter Review
Assignee: mconley → dao
Attachment #8387280 - Flags: review?(mconley)
Comment on attachment 8387280 [details] [diff] [review]
patch

Review of attachment 8387280 [details] [diff] [review]:
-----------------------------------------------------------------

Yes - this works beautifully. Thanks Dao - if it wasn't already clear from my patch, we weren't really sure how best to fix this one. :/
Attachment #8387280 - Flags: review?(mconley) → review+
Group: mozilla-employee-confidential
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
Group: mozilla-employee-confidential
https://hg.mozilla.org/mozilla-central/rev/8f7a0ade859c
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Comment on attachment 8387280 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 960517
User impact if declined: see comment 0
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #8387280 - Flags: approval-mozilla-aurora?
Attachment #8387280 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed on the latest Firefox 29 beta and Firefox 30 Aurora on Ubuntu 13.04 x86.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.