Closed Bug 978922 Opened 7 years ago Closed 3 years ago
UI-sub View class since it's used beyond sub views (Panel UI-sub View-or-toolbar-panel?!)
As per bug 972405.
Component: Theme → Toolbars and Customization
OS: Mac OS X → All
Hardware: x86 → All
Summary: Rename PanelUI-subView class to PanelUI-subView-or-toolbar-panel to better reflect its usage. → Rename PanelUI-subView class since it's used beyond sub views (PanelUI-subView-or-toolbar-panel?!)
Ok, let the contest begin! What about 'PanelUI-listView'?
Unless I'm mistaken, PanelUI refers to the thing that opens when clicking the menu button on the far right... so that would still be a lie.
(In reply to Marco Bonardo [:mak] from comment #3) > widget-subview? See the summary. ;) When used on menus or panels directly opened from the toolbar, it's not we usually refer to as a sub view. (Also, widget can mean anything, so "subview" would be as good or bad as "widget-subview".)
true, the widget name is very generic, but in Australis it has a very specific meaning, one may even go more specific as customizableWidget. On the other side, anything in the panels or subviews is some sort of view, so the name may use attachedView, linkedView or whatever similar.
No user impact, so P-, but if we're going to tweak the name it would be ideal to do so before beta.
Suggestions : firefox-widgetView ffx-widgetView widget-view customizableUI-widget-view cui-widget cui-widget-view
I think arrowpanel-menu would be well in line with how we're using that class. Thoughts, Mike and Marco?
That, or even 'panel-menu', being shorter. I won't cry if we end up using arrowpanel-menu, though.
I added "arrow" because we use the class only in arrow panels, and it might look odd if used in some other panel.
Is it still worth doing this, considered it may have a (small) impact on add-ons/themes compatibility? Honestly I don't have much insight regarding a name here. off-hand "menu" sounds very specific, in the end it's jsut a view that could also be presented as a menu. if not that we have: cui-widget-panelview, panel-subview(s), panel-viewcontainer... along with this, everything looks very confusing and undocumented. Anything that can make these classes clearer about their scope is a win. It's clear we can't add another thing looking like panel-something-view, but I'm not sure just changing panel to arrowpanel and view to menu will clarify much about scope of all these panel-view things :(
I filed bug 1427284 to remove this class instead, since it is unneeded in Photon.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.