improve table regression tests

RESOLVED FIXED

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: bernd_mozilla, Assigned: bernd_mozilla)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
after waiting to long for table qa to transfer testcases they have written to
table  regression tests I would like to do the following:
1. change layout/tests/block/rtest.bat so that goes to the same directories as
rtest.sh
2. put 
  subst s: %MOZ_SRC%      at the beginning of layout/tests/block/rtest.bat 
  subst s: /D             at the end of layout/tests/block/rtest.bat 

3. put 'viewer -B 1' in all rtest.bat files in order to avoid the tree dumping
when a regresion test fails
4.  copy the xhtml testcases from
http://mozilla.org/quality/browser/standards/xhtml/transitional/table_elements.html
to the marvin directory and include them into the filelist.txt
5. I thought I've seen also html-strict testcases if I find them I will move
them also to the marvin directory

Comment 1

17 years ago
Hmm. the name 'marvin' is unintuitive. Should we change that to 'standards' or
something, or am I just uninformed?
(Assignee)

Comment 2

17 years ago
We had the marvin directory for years, and yes I like the name, it reflects
perfect the issue: a robot who is bored because he is by several magnitudes more
intelligent than humans. Oh Marc, or should you comment mean that you did not
read *the* book.
(Assignee)

Comment 3

17 years ago
Created attachment 49351 [details] [diff] [review]
changes to block/rtest.bat

Comment 4

17 years ago
Comment on attachment 49351 [details] [diff] [review]
changes to block/rtest.bat

r=karnaze
Attachment #49351 - Flags: review+
(Assignee)

Comment 5

17 years ago
I did not find the strict testcases, so I mark this bug fixed. Points 1-4 are
now done.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.