Closed Bug 979053 Opened 7 years ago Closed 7 years ago

Fade in the placeholder and customization target outlines after entering customize mode

Categories

(Firefox :: Theme, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: mconley, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(1 file)

The dotted outlines around the toolbar customization targets, as well as the dotted outlines for the placeholders in the menu panel should be faded in after the end of the customize mode transition to make the end of the transition less jarring.
I'll have a look.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
This only adds a fade for the initially visible bits, because unfortunately Matt and I couldn't figure out how to make this work for the hover/attribute case (and without the actual attribute, we can't make the other cases work because as soon as we add the element / enter customize mode, the non-transparent color would already be set. Mike, does this look like what you want?
Attachment #8385592 - Flags: review?(mconley)
Comment on attachment 8385592 [details] [diff] [review]
fade in navbar and placeholder outlines when opening Australis customize mode,

Review of attachment 8385592 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/customizeMode.inc.css
@@ +60,5 @@
>    outline-color: rgb(102,102,102);
>  }
>  
> +#nav-bar[showoutline=true] > #nav-bar-customization-target.customization-target::before {
> +  transition: outline-color 250ms linear;

Could avoid duplicating the transition but it would duplicate a rule so meh.
Attachment #8385592 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/aefca2214dd2
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/aefca2214dd2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
Comment on attachment 8385592 [details] [diff] [review]
fade in navbar and placeholder outlines when opening Australis customize mode,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis 
User impact if declined: placeholders appear immediately instead of fading in
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8385592 - Flags: approval-mozilla-aurora?
Attachment #8385592 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.