Closed Bug 979221 Opened 7 years ago Closed 3 years ago

Video playback is not displayed correctly (pink) on Motorola Atrix (Android 2.3)

Categories

(Core :: Audio/Video: Playback, defect)

30 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox27 --- unaffected
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected

People

(Reporter: cos_flaviu, Unassigned)

Details

Attachments

(2 files)

Attached image screenshot.png
Environment: 
Device: Motorola Atrix (Android 2.3.4);
Build: Nightly 30.0a1 (2014-02-20);

Steps to reproduce:
1. Go to http://people.mozilla.com/~nhirata/html_tp/elephants-dream.webm


Expected result:
The video is correctly displayed.

Actual result:
The video is pink.

Notes:
Please check the attached screenshot;
The bug is not reproducible on other devices.
Attached file log.txt
Attached logs form logcat.
Also reproducible when sharing video camera.
Tested on http://mozilla.github.com/webrtc-landing/gum_test.html
Please make sure you file video playback related bugs over in Core :: Audio/Video.
Component: General → Video/Audio
Product: Firefox for Android → Core
Version: Trunk → 30 Branch
MediaPluginHost: Android Version is: 10
MediaPluginHost: Android Release Version is: 2.3.4
MediaPluginHost: Android Device is: MB860
MediaPluginHost: Android Manufacturer is: motorola
MediaPluginHost: Android Hardware is: olympus
MediaPluginHost: Loading OMX Plugin: nullptr
Summary: Video playback is not displayed correctly on Motorola Atrix → Video playback is not displayed correctly (pink) on Motorola Atrix (Android 2.3)
Component: Audio/Video → Audio/Video: Playback
Android 2 is no longer supported.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.