Mozilla unresponsive while moving lots of messages from search dlg at once

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: D Holroyd, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({perf})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
While spring cleaning my IMAP inbox - moving messages between folders in groups
of several thousand - none of the Mozilla windows get repainted.

On starting the transfer, there are several seconds of activity with the
throbber doing it's thing.  Then there are several seconds during which the
display-updater (or whatever) seems to be blocked, giving the impression of a
crash.  After that things return to normal - damaged regions get repainted, etc.
Seen in 0.9.3

Workaround:  Filter-delete messages from Cron :)

Updated

16 years ago
Severity: minor → normal
Keywords: perf

Updated

16 years ago
QA Contact: esther → sheelar

Comment 1

16 years ago
reporter,
can you give us your build id? Did the message you were trying to move were
large ones?  Did you use the menu item, file button, or drag and drop to move
these messages? Did you move them from imap to local or within imap account?
(Reporter)

Comment 2

16 years ago
Build ID: 2001080110

I was using Search->Search Messages... to select a subset of my inbox.  I then
select all the messages found and use the search dialogue's File menu to move
them to another IMAP folder within the same account.

None of the messages were big; the majority under 10KB.  Each set contained a
few thousand entries though - it took a couple of minutes to complete each
operation.

My impression (as someone ignorant of Mozilla's implementation) is that the
conversation with the IMAP server finishes and mozilla updates it's state: 
While doing this update, Modilla windows don't get redrawn.

 - David

Comment 3

16 years ago
Laurel,
He seems to be moving messages from the search dialog in his comments. Have you 
seen this when you move mails from the search dialog.  Looks like he is not 
doing this from the 3 pane window.

reporter,
Do you still see this behavior when you move mails from the 3 pane mail window 
on a recent build?

Comment 4

16 years ago
Updating summary as per the description of the bug.  
QA Contact: sheelar → laurel
Summary: Mozilla unresponsive while moving lots of messages at once → Mozilla unresponsive while moving lots of messages from search dlg at once
(Reporter)

Comment 5

16 years ago
Sorry for the delayed response.

Using 0.9.5, Build ID: 2001101117, I found the same behavior when deleting large
numbers (thousands) of messages in the 3 pane view's message list.  Both
originating folder and trash are on the IMAP server.  Sorry if this is not an
equivalent case.
I also see this behaviour (though not for as long) changing the 'read' status of
lots of messages at once.
David, can you reproduce it widt 1.0RC1 ? If not, set thjis bug to "worksforme"

Comment 7

16 years ago
More than one month without response.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
I think we have related bugs to this situation and those described in comment #5
which can take the place of this particular bug. Will mark this one worksforme
and provide related bug numbers:  bug 18515, bug 101836 and bug 146230.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.