Closed Bug 979575 Opened 6 years ago Closed 6 years ago

[ZTE Open 1.1] [Facebook mobile site] - Asks if you have the application and does not remember the preference

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: guigs, Assigned: colby)

References

Details

Hi, 
Into: 
On a ZTE Open with 1.1 when you navigate to facebook.com on the firefox browser, it redirects to m.facebook.com. However user is reporting that there is a pop up asking about if you use the app then asks them to download. It will download again even if facebook app is already downloaded on the homescreen. 
[https://support.mozilla.org/en-US/questions/987890]

STEPS TO REPRODUCE:
1. When I visit facebook with the browser ,
2.  asked if I want to install the app
3. I click the "cancel" option

EXPECTED RESULTS:
Facebook.com please remember the option from last time. 


ACTUAL RESULTS:
After more browsing, the site will ask if you want the app again. 



Please let me know if there is any information I could provide to help with the investigation and troubleshooting of this issue.

Thanks!!
This is a Facebook bug. Facebook shouldn't be prompting to install the app unless the request is coming from a HTTP Facebook domain within an app.
Blocks: b2g-facebook
Component: Gaia::Browser → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Ok,  thank you Jason. 
There is also an update as well ,  the issue was actually the request to disable the pop up in facebook mobile site.
(In reply to rmcguigan from comment #2)
> Ok,  thank you Jason. 
> There is also an update as well ,  the issue was actually the request to
> disable the pop up in facebook mobile site.

Right - the popup here should only be showing up if I open up the Facebook HTTP app. It shouldn't show up in any other case, but the bug here indicates that the popup is showing up.

I've reproduced this as well.
I was unable to reproduce on my ZTE Open 1.1 and Alcatel One Touch 1.3 so this may not be happening all of the time.

However, please review and provide a potential fix date.  Thank you.
Assignee: nobody → colby
Status: NEW → ASSIGNED
Priority: -- → P3
fix inbound next week
Did not ask if I wanted to install app.  Changing status to Resolved - Works for me.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.