Closed Bug 979733 Opened 7 years ago Closed 7 years ago

[Sora][PTS][HFP] TC_AG_TWC_BV_03_I & TC_AG_ECS_BV_03_I failed.

Categories

(Firefox OS Graveyard :: Bluetooth, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 947086

People

(Reporter: sync-1, Unassigned)

Details

Attachments

(2 files)

4.21 KB, application/octet-stream
Details
4.23 KB, application/octet-stream
Details
FFOS1.3 Mozilla build ID: 20140208004002
 
 
 Profile Tuning Suite Test Case:
 
 
 DEFECT DESCRIPTION:
  TC_AG_TWC_BV_03_I & TC_AG_ECS_BV_03_I failed.
 
  REPRODUCING PROCEDURES:
  
 Test case : TC_AG_TWC_BV_03_I started
 	- SDP Service record for PTS: 'Handsfree HF' successfully registered
 	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
 	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
 	- AT: SPP connect succeeded
 	- AT: Service Level Connection established
 	- AT: post SLC command sequence complete
 	- AT: RING
 	- AT: Received +CLIP: "02151790200",129
 	- AT: Incoming call established
 	- HCI: Audio Connection enabled
 	- AT: Received +CCWA: "13764726371",129
 	- WARNING (AT): +CIEV(callheld=2) received when there is no pending CHLD operation.
 	- FATAL ERROR (AT): +CIEV(callheld=1) received when there is no second call process
 	- MTC received unexpected EXIT message from AT component
 	- WARNING (AT): +CIEV(callheld=2) received when there is no pending CHLD operation.
 	- HCI: Audio Connection disabled
 	- AT: SPP disconnect succeeded
 	- MTC: Test case ended
 Final Verdict : Inconclusive
 
 Test case : TC_AG_ECS_BV_03_I started
 	- SDP Service record for PTS: 'Handsfree HF' successfully registered
 	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
 	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
 	- AT: SPP connect succeeded
 	- AT: Service Level Connection established
 	- AT: post SLC command sequence complete
 	- AT: RING
 	- AT: Received +CLIP: "02151790200",129
 	- AT: Incoming call established
 	- HCI: Audio Connection enabled
 	- AT: Received +CCWA: "13764726371",129
 	- WARNING (AT): +CIEV(callheld=2) received when there is no pending CHLD operation.
 	- FATAL ERROR (AT): +CIEV(callheld=1) received when there is no second call process
 	- MTC received unexpected EXIT message from AT component
 	- WARNING (AT): +CIEV(callheld=2) received when there is no pending CHLD operation.
 	- HCI: Audio Connection disabled
 	- AT: SPP disconnect succeeded
 	- MTC: Test case ended
 Final Verdict : Inconclusive
 
 
  EXPECTED BEHAVIOUR:
  Expect these two can be pass.
Attached file TWC Sniffer log.
Attached file ECS Sniffer log
Component: Gaia::Bluetooth File Transfer → Bluetooth
Is this a certification test that has to pass for Bluetooth? Trying to understand if this is a certification blocker for Bluetooth.
Flags: needinfo?(sync-1)
(In reply to Jason Smith [:jsmith] from comment #3)
> Is this a certification test that has to pass for Bluetooth? Trying to
> understand if this is a certification blocker for Bluetooth.


Yes, this a certification test case.
blocking-b2g: --- → 1.3?
Flags: needinfo?(sync-1)
The cause is that dialer app calls a CDMA-specific function under GSM network and results in unexpected +CIEV(callheld=2) notification. Bug 947086 already fixed the problem in central and I've verified the patch in bug 947086 comment 12 on Sora.

Kunny, please also confirm that bug 947086 comment 12 fixes the failure in your side.
Depends on: 947086
Flags: needinfo?(liukun)
(In reply to Ben Tian [:btian] from comment #5)
> The cause is that dialer app calls a CDMA-specific function under GSM
> network and results in unexpected +CIEV(callheld=2) notification. Bug 947086
> already fixed the problem in central and I've verified the patch in bug
> 947086 comment 12 on Sora.
> 
> Kunny, please also confirm that bug 947086 comment 12 fixes the failure in
> your side.

I'm going to dupe this to that bug & + that for 1.3.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 7 years ago
No longer depends on: 947086
Resolution: --- → DUPLICATE
Duplicate of bug: 947086
(In reply to Ben Tian [:btian] from comment #5)
> The cause is that dialer app calls a CDMA-specific function under GSM
> network and results in unexpected +CIEV(callheld=2) notification. Bug 947086
> already fixed the problem in central and I've verified the patch in bug
> 947086 comment 12 on Sora.
> 
> Kunny, please also confirm that bug 947086 comment 12 fixes the failure in
> your side.

Thanks, I will merge this patch and test again.
Flags: needinfo?(liukun)
You need to log in before you can comment on or make changes to this bug.