build failure in xlibrgb.c

RESOLVED WORKSFORME

Status

()

Core
XUL
--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Chris Abbey, Assigned: Roland Mainz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
System is SuSE 7.2 with XFree86 4.1 and KDE 2.2 updates, plus kernel 2.4.9 w/ maximum memory limit raised to 64GB. The compiler is:Reading specs from /usr/lib/gcc-lib/i486-suse-linux/2.95.3/specsgcc version 2.95.3 20010315 (SuSE)failure taken is:gcc -o xlibrgb.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DOJI -D_IMPL_NS_GFXONXP -DUSE_MOZILLA_TYPES   -I../../../dist/include -I../../../dist/include -I/usr/src/moz/optbld/dist/include/nspr      -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/X11R6/include   -fPIC -I/usr/X11R6/include -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -pedantic -Wno-long-long -pipe -pthread -O3  -DNDEBUG -DTRIMMED -I/usr/X11R6/include -include ../../../config-defs.h -DMOZILLA_CLIENT -Wp,-MD,.deps/xlibrgb.pp ../../../../mozilla/gfx/src/xlibrgb/xlibrgb.ccpp0: .deps/xlibrgb.pp: No such file or directory../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c: In function `xxlib_rgb_get_cmap':../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3743: warning: pointer/integer type mismatch in conditional expression../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3743: warning: return makes integer from pointer without a cast../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c: In function `xxlib_deregister_handle':../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3863: warning: suggest parentheses around assignment used as truth valuemake[3]: *** [xlibrgb.o] Error 1make[3]: Leaving directory `/usr/src/moz/optbld/gfx/src/xlibrgb'make[2]: *** [install] Error 2make[2]: Leaving directory `/usr/src/moz/optbld/gfx/src'make[1]: *** [install] Error 2make[1]: Leaving directory `/usr/src/moz/optbld/gfx'make: *** [install] Error 2.mozconfig is as follows:ac_add_options --enable-cryptoac_add_options --enable-optimize=-O3ac_add_options --disable-debugac_add_options --enable-strip-libsac_add_options --disable-teststurning the optimizations down to -O2 doesn't help any. :(

Comment 1

17 years ago
Um, how about filing with line feeds this time ...

What is the date of the source that you are building.


-> Roland.Mainz@informatik.med.uni-giessen.de
Assignee: trudelle → Roland.Mainz
(Reporter)

Comment 2

17 years ago
sigh. That *had* linefeeds in it, but the new version of bugzilla and
Konqueror don't want to get along very well it seems. (this is posted
with NN 4.77 since my mozilla tree is dead)

This tree is *current* as of right now.

system: SuSE 7.2 + X 4.1 + KDE 2.2 + kernel 2.4.9 w/ 64G max memory limit.

failure:
make[3]: Entering directory `/usr/src/moz/optbld/gfx/src/xlibrgb'
xlibrgb.c
gcc -o xlibrgb.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DOJI
-D_IMPL_NS_GFXONXP -DUSE_MOZILLA_TYPES   -I../../../dist/include
-I../../../dist/include -I/usr/src/moz/optbld/dist/include/nspr     
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/usr/X11R6/include -I/usr/X11R6/include   -fPIC -I/usr/X11R6/include -Wall -W
-Wno-unused -Wpointer-arith -Wcast-align -pedantic -Wno-long-long -pipe -pthread
-O3  -DNDEBUG -DTRIMMED -I/usr/X11R6/include -include ../../../config-defs.h
-DMOZILLA_CLIENT -Wp,-MD,.deps/xlibrgb.pp
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c
cpp0: .deps/xlibrgb.pp: No such file or directory
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c: In function `xxlib_rgb_get_cmap':
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3743: warning: pointer/integer
type mismatch in conditional expression
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3743: warning: return makes
integer from pointer without a cast
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c: In function
`xxlib_deregister_handle':
../../../../mozilla/gfx/src/xlibrgb/xlibrgb.c:3863: warning: suggest parentheses
around assignment used as truth value
make[3]: *** [xlibrgb.o] Error 1
make[3]: Leaving directory `/usr/src/moz/optbld/gfx/src/xlibrgb'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/moz/optbld/gfx/src'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/moz/optbld/gfx'
make: *** [install] Error 2

gcc version:
Reading specs from /usr/lib/gcc-lib/i486-suse-linux/2.95.3/specs
gcc version 2.95.3 20010315 (SuSE)

.mozconfig:
ac_add_options --enable-crypto
ac_add_options --enable-optimize=-O3
ac_add_options --disable-debug
ac_add_options --enable-strip-libs
ac_add_options --disable-tests

Comment 3

17 years ago
(I'm assuming this builds normally). Why is '.deps/xlibrgb.pp' missing?
What happens if you just chuck that whole xlibrgb directory and build again?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
I've chuked the entire build directory (/usr/src/moz/optbuild/) and reconfigured from 
the same sources (/usr/src/moz/mozilla/) which are current with only one change
applied (bidi #ifdefs removed) starting from scratch gets the same results; ditto "make 
clean && make".
(Reporter)

Comment 5

17 years ago
hmm. the missing deps files are actually there, in the cvs tree, but not in the build 
tree... I'm guessing that someone wasn't planning on having source and binary trees 
seperated.... sym linking to the source tree fixed the build... looking at the Makefiles 
in the source tree to figure out what's broke.....
(Assignee)

Comment 6

17 years ago
chris:
1. How recent is your tree ? I thought I fixed this issue a month ago while
switching my stuff from "../xlibrgb/xlibrgb.c in the Makefile" to "use of
xlibrgb.so" ...
2. Are you building in srcdir/ (I am usually building in a seperate objdir, e.g.
mkdir objdir; cd objdir; ../configure; gmake) ?
(Reporter)

Comment 7

17 years ago
1. The tree is current as of *right now*...
2. Seperate binary trees (I actually have two, debugbld/ and optbld/

cd /usr/src/moz/mozilla
gmake -f client.mk pull_all
cd ../optbld
make

or even if I start from scratch and do

cd /usr/src/moz/mozilla
gmake -f client.mk pull_all
cd ..
mkdir test
cd test
../mozilla/configure
make

I've looked back through some file times... it looks like this is the first clobber
build I've done since july; so it's something that's changed since then.
(Assignee)

Comment 8

17 years ago
chris:
I suggest to wipe-out your tree, download a recent nightly tarball and
update+clobber that. Many things have changed in the recent past, incl. pavlov's
img1 removal and lots of other stuff which adds/removes a lot of makefile stunts
...
(Assignee)

Comment 9

17 years ago
Any news here ?
I'd like to hunt down this issue if there is one (WFM here) ...
(Reporter)

Comment 10

17 years ago
bah. sorry, got distracted with a machine that went belly up... I've pulled a
fresh tree and the problem persists, I'll pull a tarball this weekend, and see
if it has the same problem... since it should be the same code it should have
the same problem. The only thought I have is that maybe we're building in
different locations and that has an impact. You are building in a subdirectory
of mozilla, right? I'm building in a sibling directory. (from mozilla it's
../optbld/)  That shouldn't matter though, it doesn't for other components, it
didn't for this untill recently.
(Reporter)

Comment 11

17 years ago
bizare. building from a brand new tarball (nightly) doesn't have any problems,
i've done a pull_all and cleaned out the gfx directory, it again makes fine.

well cvs diff says there is nothing different between my tree and the real tree,
yet clearly my tree was badly fubar. Let's close this out. Thanks for the
followup Roland.

Resolved -> WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.