Closed Bug 979921 Opened 6 years ago Closed 4 years ago

Follow-up on disabled tests for Android 2.3 emulator

Categories

(Testing :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gbrown, Assigned: gbrown)

References

(Depends on 4 open bugs)

Details

Attachments

(2 files)

In bug 967704, we identified many test failures in the Android 2.3 emulator, opened bugs for those, and often disabled the offending tests. Once the tests are disabled, those bugs don't really block 967704, but we should follow-up on them to see if we can get them running on Android 2.3.
No longer depends on: 967704
Depends on: 981881
Depends on: 981886
Depends on: 981889
Depends on: 981895
Depends on: 981898
Depends on: 983440
Depends on: 836818
Depends on: 986164
Depends on: 986172
Depends on: 918494
Depends on: 989485
Depends on: 995696
Depends on: 999139
I re-visited the tests I previously disabled for Android 2.3 and found that several of them appear to run fine now. This change may be due to the change from aws to ix slaves, or it may be that the root cause of the failures was addressed in other bugs -- I don't know. In any case, these tests appear to run fine now, so I want to enable them.

https://tbpl.mozilla.org/?tree=Try&rev=2b5ff5a1575b

Once this patch lands, I will update and close the affected bugs (bug 975487, 981895, etc).
Attachment #8428773 - Flags: review?(dminor)
Keywords: leave-open
Another try run, to be sure: https://tbpl.mozilla.org/?tree=Try&rev=658ed2bef2ef
Comment on attachment 8428773 [details] [diff] [review]
enable some mochitests on Android 2.3

Review of attachment 8428773 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me
Attachment #8428773 - Flags: review?(dminor) → review+
I found some crashtests that can be enabled too.

https://tbpl.mozilla.org/?tree=Try&rev=668402e61017
Attachment #8429004 - Flags: review?(dminor)
Attachment #8429004 - Flags: review?(dminor) → review+
No longer depends on: 891347
Depends on: 891347
Depends on: 1025968
Depends on: 977952
Depends on: 1028918
Depends on: 945395
Depends on: 1028929
No longer depends on: 977952
Depends on: 1030403
Depends on: 1030419
Depends on: 1030432
Depends on: 1030942
Depends on: 1031097
Depends on: 1031103
See Also: → 1251013
Android 2.3 is no longer supported in Firefox 48+.

Test manifests were updated in bug 1251013.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.