[PP] Regression: Undo is broken under POP and IMAP

VERIFIED FIXED in M9

Status

P3
major
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: pmock, Assigned: jefft)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf])

(Reporter)

Description

20 years ago
Build Date & Platform Bug Found:
  Mac Seamonkey commercial build (1999-07-13-09) installed on PPC 8600/OS Mac OS
8.5.1 and PPC 9600/300 Mac OS 8.5.1

Overview Description:
  The undo command does not work for the Move, Copy and Delete commands.  This
was working in yesterday Mac build (1999-07-12-08).  Under POP, the operation
fails consistently.  Under IMAP, it fails but behaves differently than pop.
  IMAP
    -Copy/Undo will work if you wait a long time (a few minutes) before
performing an undo commmand.
    -Delete/Undo fails but you can force it to work if you switch between the
Trash folder and Inbox.
    -Move/Undo fails in all cases.

** To be certain of our results, we waited a few minutes after performing a copy/
move/delete operation before trying the undo command.  My results were consistent
with Ninoschkas.


Steps to Reproduce:
0) It easier if you are working with one account POP/IMAP at a time that contains
few folders and a Inbox folder with less than 10 messages.  Mac performance is
extremely bad.
1) Run Apprunner
2) Open Messenger through the Task menu or Component bar
3) Double click on the server icon to expand the folder list
4) Select the Inbox
   Wait the messages to display in the thread window
5) Select a message in the thread window
   Wait for the message to load in the message pane
6) Perform one of these operations
     Delete
     Copy
     Move
7) Wait a few "minutes" then select the Edit menu and choose Undo
   The operation fails to revert the last change.


Actual Results:
  No operation occurs
  -If you performed a delete operation, then and undo command, the deleted
message was not returned to the Inbox. The Trash folder still contains the
deleted message.
  -If you performed a copy operation, then an undo command, the copied message is
has not been removed from the destination folder.
  -If you performed a move operation, then an undo command, the moved message has
not been returned to the Inbox.  It is still present in the destination folder.

Expected Results:
  The Undo command should revert the changes done by the last delete, copy, or
move command.

Additional Information:
  Due to performance problems, selecting a message or opening a folder is
painfully slow.  Thank you Ninoschka for pointing this problem out and devoting
so much effort to test this feature.

Updated

20 years ago
Assignee: phil → jefft
Severity: normal → major
Summary: Regression: Undo is broken under POP and IMAP → [PP] Regression: Undo is broken under POP and IMAP

Comment 1

20 years ago
What could have caused this regression between yesterday and today's builds??

Updated

20 years ago
Target Milestone: M9

Comment 2

20 years ago
Could be an rdf change causing this, if the change is not showing up until you
re-open the folder (I'm not saying it does, but have you checked?)
(Reporter)

Comment 3

20 years ago
Per David Bienvenu suggestions, I went back and re-tested this bug using the

1999-07-13-09. It appears that the undo command is un-reliable.  At times, I

could get it work but others it fails under POP.  Under IMAP, it is worst.  When

the undo command works, it partially undo the operation.  It leaves the message

deleted/copied/moved message in the destination folder. Closing and re-openning

the folder appears to help but not always.



Waiting for the next build to test further.

Updated

20 years ago
Whiteboard: [Perf]
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

20 years ago
Same host undo should be behaving better now.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

20 years ago
This is fixed.

Comment 6

20 years ago
Build 1999081308M9: Linux/Redhat 6.0

Delete/Undo and Copy/Undo works. Move/Undo does not work.

Steps to reproduce:
1. Using 1 IMAP account.
2. Move a message from the Inbox to the template folder.
3. Notice the message disappears from the Inbox.
4. Select Edit/Undo and nothing happens.
5. Select the Templates folder and the message remains there.
6. Restart the application and notice the message is still in the Templates
folder when it should be in the Inbox folder.
(Assignee)

Comment 7

20 years ago
Try remove the database file and then restart the app. If the messages still
exist then reopen the bug else log a bug against database. Thanks,

Comment 8

20 years ago
Linux Redhat 6.0 (1999-08-16-08 M9)
POP/IMAP:  Undo of move/copy/delete all work fine in this build

Comment 9

20 years ago
Win32 (1999-08-16-09 M9)
POP/IMAP:  Undo of Copy/Delete/Move works fine.
Mac system 8.5 (1999-08-16-08 M9)
POP: Undo of Copy/Delete/Move works fine. I have not been able to test IMAP
because it keeps crashing.  I need to do further testing on this one.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 10

20 years ago
Mac sys 8.5 (1999-08-16-08 M9)
I did some clean-up in my Mac machine.
Undo of Delete/Copy/Move works on Mac now.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.