Closed Bug 980130 Opened 6 years ago Closed 6 years ago

Bookmarks menu button breaks after reset if it used to be in the panel

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [Australis:P3+][fixed-on-fx-team])

Attachments

(1 file)

It should listen for onWidgetReset as well.
Comment on attachment 8386787 [details] [diff] [review]
bookmarks button breaks after reset in Australis customize mode,

Review of attachment 8386787 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser-places.js
@@ +1178,3 @@
>  
> +  onWidgetRemoved: function BUI_widgetRemoved(aWidgetId) {
> +    if (aWidgetId == "bookmarks-menu-button") {

it would be swell if this ID was a defined as a constant somewhere.

::: browser/components/customizableui/src/CustomizableUI.jsm
@@ +2470,5 @@
>     *     Fired after a reset to default placements moves a widget's node to a
>     *     different location. aNode is the widget's node, aContainer is the
>     *     area it was moved into (NB: it might already have been there and been
>     *     moved to a different position!)
> +   *   - onWidgetUndoReset(aNode, aContainer)

Can we rename this to onWidgetUndoMove so that it will be future compatible with when we allow undo's of single item moves?
Attachment #8386787 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/f16cb820431b
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-on-fx-team]
Updated CUI docs on MDN.
https://hg.mozilla.org/mozilla-central/rev/f16cb820431b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8386787 [details] [diff] [review]
bookmarks button breaks after reset in Australis customize mode,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: bookmarks menu doesn't behave correctly under certain circumstances
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low - we would have noticed significant issues by now.
String or IDL/UUID changes made by this patch: none
Attachment #8386787 - Flags: approval-mozilla-aurora?
Attachment #8386787 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.