Closed Bug 980182 Opened 6 years ago Closed 6 years ago

Add tests for about:accounts?action=

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: markh, Assigned: markh)

References

Details

Attachments

(1 file)

Broken out from bug 956605 - this bug is to add tests to the existing about:accounts?action=* - that the correct URL is loaded.  It gives coverage for getAccountsURI/getAccountsSignInURI/promiseAccountsForceSigninURI in FxAccounts.jsm
This has much of the test changes from bug 956605.  It restructures the tests a bit (eg, no need to have a setup function as it's not shared - it keeps teardown as that is still executed even on failure).  It also makes the test e10s friendly should about:accounts ever end up in a content process.
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #8386561 - Flags: review?(ttaubert)
Comment on attachment 8386561 [details] [diff] [review]
0001-Bug-980182-more-about-accounts-tests.-r-ttaubert.patch

Review of attachment 8386561 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the possible source of intermittent failures fixed.

::: browser/base/content/test/general/browser_aboutAccounts.js
@@ +67,5 @@
> +  {
> +    const expected_url = "https://example.com/?is_sign_in";
> +    setPref("identity.fxaccounts.remote.signin.uri", expected_url);
> +    let tab = yield promiseNewTabLoadEvent("about:accounts?action=signin");
> +    return waitForIframeLoad(tab).then(

I worry that this might fail intermittently when the order of events and messages gets messed up. Can we have a dedicated function that creates a new tab and just listens for the iframe load?
Attachment #8386561 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/7c69522060eb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8386561 [details] [diff] [review]
0001-Bug-980182-more-about-accounts-tests.-r-ttaubert.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: N/A - test only fix - will give better testing on 29, and allow easier uplift
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): None 
String or IDL/UUID changes made by this patch: None
Attachment #8386561 - Flags: approval-mozilla-aurora?
Blocks: 956605
Attachment #8386561 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.