Bad sizing on select when width = 100%, selected != 1

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: Greg Valure, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build ID: 2001080110 (0.9.3 milestone)
Reproducible: Always

Open a Mozilla window that's not maximized and show the first test case in it. 
It has a 100% width single cell table with a select control set to style="width:
100%".  The second option has the selected attribute.  If you make the window
larger, the table/select will stretch to fit, as it should.  If you make it
smaller, they will shrink down until they reach their size when the page was
first opened and then cause a scrollbar to appear instead.  If you shift-reload,
it will reset the minimum size and then behave the same.

Now do the same with the second test case.  What's interesting is that this
doesn't happen if there is no selected attribute, it's given to the first
option, or the control isn't put into a table.
The third test case just shows some additional weirdness that happens to other
cells when this happens.  The top right cell is at 100% so the top left
shouldn't ever grow, but it does when the scroll bar appears.  This will most
likely clear up by itself once the bug is fixed, though.
(Reporter)

Comment 1

17 years ago
Created attachment 48028 [details]
testcase, shows problem
(Reporter)

Comment 2

17 years ago
Created attachment 48029 [details]
testcase, similar combinations that work
(Reporter)

Comment 3

17 years ago
Created attachment 48030 [details]
testcase, collateral table weirdness

Comment 4

17 years ago
works for me build 2001082909 win32

Comment 5

17 years ago
ok, must have been sleeping or something

confirmed on build 2001082909 win32

weird bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

17 years ago
WFM 2001111603 Win98
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: madhur → tpreston
You need to log in before you can comment on or make changes to this bug.