Closed Bug 980254 Opened 7 years ago Closed 7 years ago

contentScript.inject cannot work

Categories

(Testing Graveyard :: JSMarionette, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 985112
1.4 S4 (28mar)

People

(Reporter: gduan, Assigned: evanxd)

References

Details

When trying to client.contentScript.inject(some script), it will have error as below.

 JavaScriptError: (17) No such strategy.
  Remote Stack:
  <none>
Evan, you listed this bug on the weekly report. Please give out a brief update on what's done last week in the comment here.
Flags: needinfo?(evanxd)
Hi all,

After the investigation, we could use the contentScript.inject after we set version of marionette-js-client as v1.0.0. See the change at https://github.com/evanxd/gaia/commit/248ea4182d1325ec016f27f1d78a54e15f3d18a1.

After set the version, we could run the test included contentScript.inject with doing `make test-integration-test TEST_FILES=apps/calendar/test/marionette/alarm_test.js`.

I'm investing the issue of marionette-js-client ~1.1.0.
Flags: needinfo?(evanxd)
I think it is a duplicated bug of Bug 985112.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985112
Assignee: nobody → evanxd
Target Milestone: --- → 1.4 S4 (28mar)
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.