Closed Bug 980338 Opened 9 years ago Closed 9 years ago

Everything is scaled up when using large fonts

Categories

(Firefox :: Untriaged, defect)

27 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 851268

People

(Reporter: andrixnet, Unassigned)

Details

Attachments

(7 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

Set your display to large fonts.
Visit a webpage. 
In my case, I observed the issue while working as a developer for www.rador.ro
The website is designed for 960px width. 


Actual results:

The entire page (both text and images) are scaled up 125% (which is the same amount of scaling that is done for the fonts as set by display properties. 

This happens on WinXP and Win7, at least. 
Happens on Firefox and on Seamonkey. 

According to View->Zoom, page display is at 100%. Inspecting elements with Firebug yields their correct size in pixels. However, if I do a printscreen on anything, including an image of 960px displayed as 100% size, I get an image of 1200px.

I have done a comparison : 
- Chrome: page is displayed correctly, 1:1 pixel size
- Opera: page is displayed correctly, 1:1 pixel size
- Internet Explorer: page is displayed upscaled 125%, and Tools->Zoom defaults to 125%. Setting to 100% shows the page correctly. 
- SeaMonkey: same as Firefox: page is displayed upscaled 125%, View->Zoom defaults to 100%, yet the page is scaled up. Scaling is visible on some images and distorting. 

The fact that Firefox upscales the entire page, not just fonts, is the first problem and the second problem is the fact that Firefox denies the upscaling process. 

I will attach print screens illustrating the situation.


Expected results:

Page should be displayed as is at 100%.
Application sould follow Fonts should be scaled according to system setting. 
If same scaling is to be applied to entire page (including images), it should be declared as such and the a new zoom level should become the default, with the option to the user to change the default to follow system display dpi, or stay at 100%.
Attached image firefox.png
As you can see, the actual image is 1200px, or 125% the original. 
Firefox says it is displaying at 100%, or, resetting view->zoom yields no change.
Attached image seamonkey.png
same behaviour in seamonkey.
Attached image chrome.png
chrome displays correctly at 100%
Attached image opera.png
Opera displaying correctly
Attached image internet-explorer.png
Attached file no large fonts.zip
Here are print screens with each browser, with the display set to default font size, 100%, no scaling. 

Illustrated are Firefox's reporting of image sizes in title bar and with Firebug, and the actual pixel sizes, and zoom menu in Internet explorer.
The change is intentional (bug 844604). Since Firefox 22 follows the dpi settings of the system.

There is a setting to disable the adjustment mentioned in bug 851268 comment 11.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
IE most certainly does scale webpages up according to the DPI scale. The only difference is it shows the zoom level in terms of device pixels (so you see 125% is chosen as the default zoom instead of 100%.)

If you want the default to be device pixels, please vote for Bug 892888 or install the NoSquint addon.
You need to log in before you can comment on or make changes to this bug.