Closed Bug 980361 Opened 7 years ago Closed 7 years ago

The keyboard doesn't close after pressing a disabled button

Categories

(Firefox OS Graveyard :: Gaia, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S3 (14mar)

People

(Reporter: rafael.marquez, Assigned: crdlc)

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

*Procedure
1. Enter in Home Screen Edit Mode by long-pressing an icon.
2. Tap on a bookmark icon to open edit bookmark screen
3.  Tap on  website name field
4. Delete all bookmark name
5. Press "done" button while it's disabled

*Expected Result
The keyboard automatically closes when you press the button done

Keyboard is closed
The keyboard doesn't close after pressing a disabled button
Whiteboard: [systemsfe]
Moving to Gaia component because I saw that this issue is in BBs. Disabled buttons defined in header.css have to add "pointer-event: none" like button.css does. I confirmed it with Arnau
Status: NEW → ASSIGNED
Component: Gaia::Homescreen → Gaia
Assignee: nobody → crdlc
Attached file Patch v1
Thanks Arnau
Attachment #8386844 - Flags: review?(arnau)
Rafa,

  If you try it:

1) Add a new bookmark
2) Go to edit mode
3) Open the UI to delete this bookmark
4) Cancel because you do not want to delete it :)
5) Enter in the UI to edit the bookmark

  Now, you don't see the bug. It is because of the UI for deleting apps/bookmarks imports the button.css building block. Thanks to this flow, I realized why reason was working badly

Thanks
blocking-b2g: --- → 1.4?
OS: Other → Gonk (Firefox OS)
Hardware: Other → All
Comment on attachment 8386844 [details]
Patch v1

Easy one, thanks Cristian!
Attachment #8386844 - Flags: review?(arnau) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/90663f8d3371cfae4c28ee74f5552db8cf5ef380
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
already landed in master so clearing v1.4? flag
blocking-b2g: 1.4? → ---
Target Milestone: --- → 1.4 S3 (14mar)
Added a missed style in the BB of headers approved by Arnau. Test does not make sense here
Flags: in-testsuite-
Verified in master branch (1.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.