Closed Bug 980445 Opened 6 years ago Closed 6 years ago

Bookmarks menu button hover/pressed state issues

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: Gijs, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

(Keywords: polish, Whiteboard: [Australis:P3-])

Attachments

(1 file, 1 obsolete file)

I think these are all fixable in one go, so, noting here:

- the separator is off by 1px compared to where the hover border starts
- the active style for the dropmarker doesn't show the hover style for the star part of the button (not tested the reverse, but that should obviously also work)
- on hover/active, the dropmarker part is noticeably bigger than the star part
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
I'll add one more issue to this list :)

There is a white shadow at the bottom of the hovered part of the item. This shadow should always extend over the entire width of the combined element.
Depends on: 980374
Putting this up here to show the progress, while working on getting bug 980374 landed without test failures.
Comment on attachment 8389845 [details] [diff] [review]
Patch v1: adjust Bookmarks button border state on hover and panel open

Review of attachment 8389845 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this is much better! Good stuff!
Attachment #8389845 - Flags: review?(mconley) → review+
Thanks!

Pushed to fx-team as: https://hg.mozilla.org/integration/fx-team/rev/e41244dad384
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e41244dad384
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
Comment on attachment 8389845 [details] [diff] [review]
Patch v1: adjust Bookmarks button border state on hover and panel open

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 909349
User impact if declined: Bookmarks star button and dropmarker will have the wrong hover states without this patch applied.
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): minor
String or IDL/UUID changes made by this patch: n/a
Attachment #8389845 - Flags: approval-mozilla-aurora?
Attachment #8389845 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.