Closed Bug 980456 Opened 8 years ago Closed 8 years ago

[B2G][FTE][Date & Time] Continent and city selections aren't displayed highlighted

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: tnguyen, Assigned: flod)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot
Description:
When user changes continent and/or city on Date & Time screen during FTE/FTU, the locations don't appear highlighted in the image. 

Repro Steps:
1) Updated Buri to BuildID: 20140306040204
2) Open Settings App
3) Navigate to Device Information>More Information>Reset Phone
4) On FTE, select next until Date & Time screen is reached
5) Tap "Change" button next to current city
6) Select new city
7) Tap "OK"

Actual Result:
Timezone and city image does not reflect the changes made

Expected Result:
Timezone and city image reflects the changes made

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140306040204
Gaia: 9cb35e701df44766d9b3560b0defe0a401a0ecdd
Gecko: 8122ffa9e1aa
Version: 30.0a1
v1.2-device.cfg

Attached: screenshot
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965912
Attached image working_screenshot
I'm attaching a new screenshot to show the Date & Time working correctly on latest Buri build v1.3 side by side with the same page as Master M-C to better represent this issue. The continents are not being colored/highlighted in at all, this is not a dupe of bug 965912 and therefore I'm reopening. 

~Issue does not reproduce v1.3~
Device: Buri v1.3 mozRIL
BuildID: 20140307004004
Gaia: e8bf7326ce5ed63bc8ef8b2cff1eba094887b9bf
Gecko: 4efa30fe00e7
Version: 28.0
v1.2-device.cfg
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
blocking-b2g: --- → 1.4?
QA Contact: mvaughan
The following regression window was found using b2g-inbound builds:

- Last Working -
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140305060225
Gaia: 2f72fbc4dd068bb6cce8d63b02c852fa19cb38d2
Gecko: c148486b6108
Version: 30.0a1
Firmware Version: V1.2-device.cfg

- First Broken -
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140305061723
Gaia: 48e101917a73e228b27537d30254d276a4721dae
Gecko: 2fc31a6b0cbf
Version: 30.0a1
Firmware Version: V1.2-device.cfg

**This is a gaia issue**
Push log: https://github.com/mozilla-b2g/gaia/compare/2f72fbc4dd068bb6cce8d63b02c852fa19cb38d2...48e101917a73e228b27537d30254d276a4721dae
Broken by bug 975637.
Blocks: 975637
Assignee: nobody → francesco.lodolo
I have a patch working locally, but I can't add attachments to bugzilla or request review
https://github.com/mozilla-b2g/gaia/pull/17038

Tested and working locally on Keon.

Old hardcoded 'UTC' was used to generate the CSS class name that highlights the region.
Travis is dying on connection problems, opening a needinfo with the original reviewer
https://github.com/mozilla-b2g/gaia/pull/17038
Flags: needinfo?(fernando.campo)
Attached file Pull request
Old code used regexp to change strings like "UTC+05:00" to "UTC0500", to obtain the class name used to highlight regions.

New code applied the regexp only to "+05:00", resulting in the wrong class name.

Note: also need someone to check-in this patch if bug 975637 isn't backed out in the meantime, since this is considered a blocking regression (see bug 975637 comment 40).
Attachment #8388677 - Flags: review?(fernando.campo)
Flags: needinfo?(fernando.campo)
Comment on attachment 8388677 [details] [review]
Pull request

I think this was removed by mistake?
Attachment #8388677 - Flags: review?(fernando.campo)
(In reply to Gregor Wagner [:gwagner] from comment #9)
> Comment on attachment 8388677 [details] [review]
> Pull request
> 
> I think this was removed by mistake?

Did I remove the review flag? I though I was removing only the needinfo.
I'll ping fcampo or a FTE peer this morning on IRC to speed things up.
Comment on attachment 8388677 [details] [review]
Pull request

Code is OK (sorry I missed that in the first review), but it needs a test. 
Should be simple, something in the line of:

var timezoneOverlay = document.getElementById('time_zone_overlay');

test('should highlight timezone', function() {
  timezoneOverlay.className = 'UTC' + FAKE_TIMEZONE.utcOffset.replace(/[+:]/g, '');
});

Anyway, r+ proven the test is added and travis green after that.
Thanks for the quick fix!
Attachment #8388677 - Flags: review?(fernando.campo)
Attachment #8388677 - Flags: review+
Thanks, added test, now waiting for Travis.
Master: a6fed6722d18920cbe880b811e2a9dbeea46bfe7
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
blocking-b2g: 1.4? → 1.4+
Verified on Keon, Gaia Git commit 905c9409 (2014-03-11 14:26:17): regions are correctly highlighted when region/city change.
Status: RESOLVED → VERIFIED
(In reply to Tony Nguyen from comment #0)
> 3) Navigate to Device Information>More Information>Reset Phone

Forgot one note for the reporter: you don't need to reset the phone, just go to Settings-Developer, there's a button to start FTE there.
Duplicate of this bug: 982910
You need to log in before you can comment on or make changes to this bug.