Closed Bug 980480 Opened 6 years ago Closed 6 years ago

hit testing and boundaries fail on retina displays

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

No description provided.
*2 helps for hit testing, /2 doesn't help for position.

Robert, do you know what's special in Retina displays?
Summary: hit testing and boundareis fail on rethina displays → hit testing and boundaries fail on retina displays
Retina displays are high DPI. Is this bug referring to something internal to Firefox or did you test it using an AT?

In Windows, Firefox is DPI aware and exposes physical coordinates, so as long as the AT is DPI aware, it should just work. Note that NVDA 2013.3 and earlier aren't DPI aware, so this caused nasty problems until high DPI awareness was implemented.
It's rather something Firefox internal because Chrome works with VoiceOver just fine
Attached patch patchSplinter Review
Attachment #8387669 - Flags: review?(trev.saunders)
Assignee: nobody → surkov.alexander
Comment on attachment 8387669 [details] [diff] [review]
patch

>   nsCOMPtr<nsIAccessible> deepestFoundChild;
>-  mGeckoAccessible->GetDeepestChildAtPoint((int32_t)geckoPoint.x,
>-                                           (int32_t)geckoPoint.y,
>+  mGeckoAccessible->GetDeepestChildAtPoint(geckoPoint.x,
>+                                           geckoPoint.y,
>                                            getter_AddRefs(deepestFoundChild));

while your here you might as well change that to ChildAtPoint(x, y, eDeepestChild)
Attachment #8387669 - Flags: review?(trev.saunders) → review+
Comment on attachment 8387669 [details] [diff] [review]
patch

>diff --git a/accessible/src/mac/mozAccessible.mm b/accessible/src/mac/mozAccessible.mm

>+  NSView* mainView = (NSView*)[[NSScreen screens] objectAtIndex:0];

These all need to be NSScreen instead of NSView.
https://hg.mozilla.org/mozilla-central/rev/9cf34c82f975
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 903585
You need to log in before you can comment on or make changes to this bug.