Closed Bug 980581 Opened 7 years ago Closed 7 years ago

Previous video clip title remains when a new video clip is selected

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: diego, Assigned: rnicoletti)

References

()

Details

(Whiteboard: [CR 618909][priority])

Attachments

(2 files)

It remains for for less than a second, but it's still noticeable.
Attached file Screen recording
This issue is reproducible on v1.4 in both QRD 8926 and a 7x27A (ICS) device.
Hi John,

Do you agree this is a bug? Maybe the video playback title should be immediately wiped when a new clip is selected.
Flags: needinfo?(johu)
Whiteboard: [CR 618909]
Hi Diego,

Yes, it's a bug. It is caused by that the code [1] is executed before [2]. The current version may be move the code [1] to the callback function of setVideoUrl[3].

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L904-L906
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L940-L949
[3] https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L928
Flags: needinfo?(johu)
There is another candidate that move the code [2] before [1] which shows title immediately but black screen at the video element.

In contrast, if we move the [1] to [3], the screen may wait few milliseconds after user taps the thumbnail. After that, the title and video will be ready at the same time.

Basically, this is a small defect of UI. The tablet is also affected.

(In reply to John Hu [:johnhu][:johu][:醬糊小弟] from comment #3)
> Hi Diego,
> 
> Yes, it's a bug. It is caused by that the code [1] is executed before [2].
> The current version may be move the code [1] to the callback function of
> setVideoUrl[3].
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L904-
> L906
> [2]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L940-
> L949
> [3]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/video/js/video.js#L928
Russ,

Since you are working on video app recently, I hope you may find this bug. It's easy and worth to fix it, but not a blocker.
Ok, I will take a look.
Assignee: nobody → rnicoletti
Status: NEW → ASSIGNED
Whiteboard: [CR 618909] → [CR 618909]
Whiteboard: [CR 618909] → [CR 618909][priority]
Comment on attachment 8392653 [details] [review]
Pull request: https://github.com/mozilla-b2g/gaia/pull/17260

Thanks for this patch. It's a nice patch.
Attachment #8392653 - Flags: review?(johu) → review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → 1.4+
The patch works for me. Thanks Russ!
Please post a link to the revision when you merge the PR.
Master: https://github.com/mozilla-b2g/gaia/commit/5bb95e384f8923963c1990a55cb297996a0f2645
Flags: needinfo?(rnicoletti)
v1.4: a6247c0f2389127d3d244bf4bfc9793ea4517d75
Target Milestone: --- → 1.4 S4 (28mar)
Regarding comment #10, I will post the link for future merges. Thanks for letting me know.
Flags: needinfo?(rnicoletti)
Flags: in-moztrap?(ychung)
New test case needs to be added. There is no existing test case.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
New moztrap test case written:

https://moztrap.mozilla.org/manage/case/14200/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(ychung)
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.