Closed Bug 980642 Opened 6 years ago Closed 6 years ago

Win7 glass window control buttons are now foggy when using OMTC

Categories

(Core :: Graphics: Layers, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- verified

People

(Reporter: jmjjeffery, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P5] [testday-20140530])

Attachments

(5 files, 2 obsolete files)

Win7 7 Articulation buttons, minimize/window/close in the upper right-corner now have a fog appearance. 

I suspect caused by buy 940455 

Tested on win7 x64 tinderbox m-c builds.

Good: 20140305182106 8122ffa9e1aa
Bad: 20140306041406 0f81cbeae0d4

patches in cset:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8122ffa9e1aa&tochange=0f81cbeae0d4

bug noted above stand-out to me as the cause.
Summary: Win7 articulation buttons are now foggy → Win7 glass window control buttons are now foggy
Whiteboard: [Australis:P2]
Sounds like perhaps the same issue as bug 980452.
This should be fixed by the backout of bug 940455.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 981645
This is back now that bug 940455 is back.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla30 → ---
Graphics
--------

Adapter Description: ATI Radeon HD 3200 Graphics
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 256
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
Device ID: 0x9610
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 7-28-2011
Driver Version: 8.881.0.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 3200 Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Oh, you have OMTC enabled? That would explain it :)
Just to clarify, we're not shipping OMTC at the moment, and I haven't implemented the clearing code for OMTC.

But it's cool that people are testing this, so I'll try get a patch up this week to fix it.
Assignee: nobody → matt.woodrow
Cool - that gives us some nice breathing room. I'm going to downgrade the priority of this bug.
Whiteboard: [Australis:P2] → [Australis:P5]
Summary: Win7 glass window control buttons are now foggy → Win7 glass window control buttons are now foggy when using OMTC
I don`t have OMTC on (GPU Accelerated Windows: 1/1 Direct3D 10) and I get the same foggy control buttons but only for ~1 second if I toggle with the Menu Bar or if I resize Firefox from left to right. 
I logged bug 980452 that was marked as duplicate of this one.
Attached patch Clear rect for OMTC (obsolete) — Splinter Review
I'll split this into multiple patches before landing, don't have good tools for doing that on this laptop.
Attachment #8391024 - Flags: review?(bas)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #10)
> I don`t have OMTC on (GPU Accelerated Windows: 1/1 Direct3D 10) and I get
> the same foggy control buttons but only for ~1 second if I toggle with the
> Menu Bar or if I resize Firefox from left to right. 
> I logged bug 980452 that was marked as duplicate of this one.

I expect this is fixed by bug 982812.
(In reply to :Gijs Kruitbosch from comment #12)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #10)
> > I don`t have OMTC on (GPU Accelerated Windows: 1/1 Direct3D 10) and I get
> > the same foggy control buttons but only for ~1 second if I toggle with the
> > Menu Bar or if I resize Firefox from left to right. 
> > I logged bug 980452 that was marked as duplicate of this one.
> 
> I expect this is fixed by bug 982812.

No, still foggy - just tested using latest m-c tinderbox hourly build with cset: 
https://hg.mozilla.org/mozilla-central/rev/83c9853e1364
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #13)
> (In reply to :Gijs Kruitbosch from comment #12)
> > (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #10)
> > > I don`t have OMTC on (GPU Accelerated Windows: 1/1 Direct3D 10) and I get
> > > the same foggy control buttons but only for ~1 second if I toggle with the
> > > Menu Bar or if I resize Firefox from left to right. 
> > > I logged bug 980452 that was marked as duplicate of this one.
> > 
> > I expect this is fixed by bug 982812.
> 
> No, still foggy - just tested using latest m-c tinderbox hourly build with
> cset: 
> https://hg.mozilla.org/mozilla-central/rev/83c9853e1364

Yes, but that's *with* OMTC, whereas Bogdan is testing without... Without is fixed, with takes the patch that Matt posted here and needs to split up before asking for review. :-)
Attachment #8391024 - Attachment is obsolete: true
Attachment #8391024 - Flags: review?(bas)
Attachment #8392613 - Flags: review?(roc)
Attachment #8392618 - Flags: review?(bas)
Attachment #8392617 - Flags: review?(bas) → review+
Attachment #8392618 - Attachment is obsolete: true
Attachment #8392618 - Flags: review?(bas)
Attachment #8392675 - Flags: review?(bas)
Attachment #8392675 - Flags: review?(bas) → review+
Is there a way to have a reference test to "protect" us from this regressing?  Or do we have one already?
Confirming this is now fixed using cset: 

https://hg.mozilla.org/mozilla-central/rev/88ae1bfaaf3d

on win7 x64 , latest m-c tinderbox (hourly) build.
(In reply to Milan Sreckovic [:milan] from comment #21)
> Is there a way to have a reference test to "protect" us from this
> regressing?  Or do we have one already?

We don't have one, and I don't know how we could unfortunately. The window control buttons are drawn by DWM, so won't exist in any readback/snapshots we do of our content. We'd need to a way to snapshot through the OS to get them included.
Matt, because bug 940455 landed on 30, can we safely uplift this to 30 as well, and if so, could you do the requisite approval requests? Thanks!
Flags: needinfo?(matt.woodrow)
Comment on attachment 8392613 [details] [diff] [review]
Clear up clearFBRect API

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 880031
User impact if declined: 'fog' covers the window control buttons with OMTC enabled.
Testing completed (on m-c, etc.): Tested locally and by other users, but OMTC isn't a default setting so no widespread or automated coverage.
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None
Attachment #8392613 - Flags: approval-mozilla-aurora?
Flags: needinfo?(matt.woodrow)
Attachment #8392613 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
WONTFIXing for 29, since bug 983638 works around the issue there.
QA Whiteboard: [good first verify]
Verified fixed using Windows 7 64 bit (es-AR) and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0. Verified in latest Nightly as well.
Status: RESOLVED → VERIFIED
Whiteboard: [Australis:P5] → [Australis:P5] [testday-20140530]
You need to log in before you can comment on or make changes to this bug.