Closed Bug 980672 Opened 7 years ago Closed 7 years ago

[B2G][Cost Control] Disabling Data use alert does not deactivate Limit picker

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: pbylenga, Assigned: mai)

References

Details

(Whiteboard: [fxos-bug-bash-1.4])

Attachments

(3 files)

Description:
In Cost Control, deactivating Data Use Alert does not disable (grey out) the Data Limit Picker.

Repro Steps:
1) Update a Buri to BuildID: 20140306134106
2) Launch Cost Control (Usage app)
3) After setup navigate to Settings
4) Enable and then Disable Data Use Alert

Actual:
Data Use limit picker is not greyed out

Expected:
Data Use limit picker is greyed out again after disabling Data Use Alert

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140306134106
Gaia: 98cf46d6623b164845fe1fdc99a2a7bf64aa667d
Gecko: 8095b7dd8f58
Version: 30.0a1
Firmware Version: v1.2-device.cfg


Notes:

Repro frequency: 5/5, 100%
See attached: screenshot
I can not reproduce the bug on the following build:
Device: Buri
Build ID: 20140307080914
Platform Version: 30.0a1

Please, could you attach your logcat output?
Regards
Keywords: qawanted
Attached file Data_Use_Limit_log.txt
Looks like there is an additional step of resetting mobile usage which I had done earlier during bug bash.

Logcat shows:
Launching Usage
Attempting to repro bug by enabling and disabling limit (failed to reproduce)
Reset Mobile Usage
Attempting to repro bug by enabling and disabling limit (was able to reproduce).

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140306134106
Gaia: 98cf46d6623b164845fe1fdc99a2a7bf64aa667d
Gecko: 8095b7dd8f58
Version: 30.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Assignee: nobody → mri
Attached file patch v1.0
The problem is related with the splitting of the bug 858017. Missing the load of NetworkDataUsage library on index.html.
Attachment #8388434 - Flags: review?(salva)
blocking-b2g: --- → 1.4?
Blocks: 858017
Duplicate of this bug: 981594
Blocks: 973590
No longer blocks: 973590
Comment on attachment 8388434 [details] [review]
patch v1.0

Ok. Working now. Thank you.
Attachment #8388434 - Flags: review?(salva) → review+
Master: 62be83e42624ae901852f05f7f5e82a67b388ca5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Already landed in master so clearing v1.4? flag and asking for v1.3T?. Thanks!
blocking-b2g: 1.4? → 1.3T?
Target Milestone: --- → 1.4 S3 (14mar)
blocking-b2g: 1.3T? → 1.3T+
Hi Ying Xu, heard that you will be doing uplifts to 1.3T branch. After you completed the uplift, can you please set status-b2g-v1.3T to fixed? please let us know if you have problems with it. thanks
Flags: needinfo?(ying.xu)
Tested and working
Hamachi
1.3
Platform version: 28.0
Build ID: 20140311092630
Git commit: 8d235a28
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.