Closed Bug 980720 Opened 7 years ago Closed 7 years ago

[Settings] Some ringer tones play no sound, cannot be selected

Categories

(Firefox OS Graveyard :: Gaia::Ringtones, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S3 (14mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: mikehenrty, Assigned: squib)

References

Details

(Keywords: regression, Whiteboard: [fxos-bug-bash-1.4])

Build Information
Device: Buri
Build ID: 20140306134106
Platform Version: 30.0a1
Gaia: 98cf46d6623b164845fe1fdc99a2a7bf64aa667d
Gecko: 8095b7dd8f58

Description
When changing the ringer tone, certain selectable ringtones (classic prism, classic electric, and class wallphone) play no sound, and you cannot click done.

Steps to Reproduce

1. Open Settings->Sound
2. Click to change current ringer
3. Select classic prism, classic electric, or classic wallphone
4. Click Done in the upper right

Expected Results
The selected ringer tone will play when you select it. When you click done, it will return to the Sound menu.

Actual Results
No ringer tone is played upon selection. Clicking done only highlights the button, but does not close the form or change the ringer tone.

Reproduction Frequency: 100%
Note: same thing happens for Alerts sounds (rewind, exclamation, ring, minimal bands). It seems any lower cased ringer/alert names dont actually have sounds to back them up.
Definitely a regression.

QA wanted to check 1.3 behavior.
Component: Gaia::Settings → Gaia::Ringtones
Keywords: qawanted
This bug does not occur on the latest 1.3 build. All alerts and ringers play as expected.

Environmental Variables
Device: Buri v1.3 Moz Ril
Build ID: 20140310004001
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/00f249d54bda
Gaia: 78c30d7ed6f6e30337d6c05453b867f5e97e42bc
Platform Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: croesch
blocking-b2g: --- → 1.4?
Marking it 1.4+ because it is regression. Jim, can you investigate.

Thanks!
Assignee: nobody → squibblyflabbetydoo
blocking-b2g: 1.4? → 1.4+
Presumably an incomplete backout of bug 964584 (see also bug 979558). Not sure why that bug was backed out of 1.4, since I don't think we're so worried about bustage that we can't even fix our l10n files.
Blocks: 964584
I have backed out bug 964768.  I verified all ringtones and alerts can be played from settings now.

Again, I backed out the conversion on 1.4 until we could get the l10n strings figured out correctly.  Unfortunately I have too many other bugs I'm working now to do that any time soon.  (And apparently I am too overloaded to handle a simple back out well either.)

Again, sorry for the bustage!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
You need to log in before you can comment on or make changes to this bug.