Closed Bug 980799 Opened 8 years ago Closed 8 years ago

[dev][stage] Adding review to an app does not appear, only after page reload

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
2014-03-11

People

(Reporter: AndreiH, Assigned: mat)

References

()

Details

(Keywords: regression, Whiteboard: [fromAutomation])

STR:

1. Go to https://marketplace-dev.allizom.org
2. Login and choose an app
3. Add a review and inspect the changes.

Expected results:
Review should instantly appear in the "Last 2 reviews section"

Actual results:
Review is not present in the reviews, only after page refresh.

Note: When deleting the review, it disappears only after refreshing the page.
This was not the expected behaviour before. Tests started failing today.
On production the behaviour is still the same.

Here is some screencasts:
This is happening on dev and stage: http://screencast.com/t/EGefMq4957
This is on prod: http://screencast.com/t/Fb3GQXoe5nsd
Whiteboard: [fromAutomation]
Keywords: regression
Target Milestone: --- → 2014-03-11
I attempted to reproduce this in my local environment using the current code on master but I was unsuccessful. The review did appear instantly and deletion worked as well.
(In reply to Andrew Halligan from comment #1)
> I attempted to reproduce this in my local environment using the current code
> on master but I was unsuccessful. The review did appear instantly and
> deletion worked as well.

You can reproduce on -dev though, right?
(In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> (In reply to Andrew Halligan from comment #1)
> > I attempted to reproduce this in my local environment using the current code
> > on master but I was unsuccessful. The review did appear instantly and
> > deletion worked as well.
> 
> You can reproduce on -dev though, right?

Yes, on -dev I can reproduce the review not appearing until a page refresh. Although, deletion seems to work properly on my end.
ashes of the adding review part on dev in case that helps: 5ecfc
Assignee: nobody → mpillard
Priority: -- → P1
Found it. I caused that regression in https://github.com/mozilla/fireplace/commit/843a4ad3c62ca13c313ceaa26a97c44197d2bd75

Fixed in https://github.com/mozilla/fireplace/commit/dfa37fba96ebc706e0893d72fee44d1b5e7415b2
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified as fixed : http://screencast.com/t/wTLi4aEj
Status: RESOLVED → VERIFIED
Please note that this is still reproducible on Stage
(In reply to Victor Carciu from comment #7)
> Please note that this is still reproducible on Stage

We haven't updated stage yet.
You need to log in before you can comment on or make changes to this bug.