Closed Bug 980878 Opened 7 years ago Closed 7 years ago

Camera takes VGA pictures on 5Mp device

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: gerard-majax, Assigned: wilsonpage)

Details

(Keywords: regression, Whiteboard: [landed-in-master])

Since around feb 20, pictures taken by Camera on Nexus S are VGA sized, instead of 5Mp.

STR:
 0. Take a picture
 1. Go to gallery
 2. Tap on the picture, then tap the 'i' button (informations)

Expected:
 Picture size should be 5Mp

Actual:
 Picture size is VGA (640x480)
blocking-b2g: --- → 1.4?
Changing source code of camera app, enabling the Settings menu, and setting picture size to 5Mp, I get correctly sized pictures.
My previous STRs were incompletes:

STR:
 0. Hack apps/camera/js/config/app.js and force 'showSettings' to true. This eases checking, it's not mandatory.
 1. Start Camera app, tap on the Settings button, then Camera resolution, select 5Mp
 2. Kill the app, restart it, and check Camera resolution is still 5Mp
 3. Reboot, recheck Camera resolution, should still be 5Mp
 4. Take pictures, they are recorded at 5Mp.

This proves the resolution is okay.

 5. Kill Camera app
 6. Start Messages, compose a new message
 7. Tap the attachment button, select Photo/Camera
 8. When the Camera app is launched, tap on settings, and check the Camera resolution setting is now VGA

This is expected, we are in a pick activity for MMS, we are targetting pictures < 300KB, hence VGA is okay.

 9. Take a picture or cancel the activity
 10. Kill the camera app
 11. Start the camera app

Expected:
 Settings's Camera resolution is back at 5Mp

Actual:
 Settings's Camera resolution is still VGA


Re-forcing the setting is okay, it works. But the issue is quite bad, because the settings menu is hidden by default. It means people will get VGA only after sending a MMS at least, and with no way to get back 5Mp.
I understand the problem. Myself and djf discussed this very issue during a code review, and I am hopeful this is fixed in 'camera-new-features' branch. I will have to clarify this though.

If camera-new-features doesn't land in master for 1.4, this will have to be patched.
This happens on Peak and Nexus S, I'm sure it's not device related.
Summary: Camera takes VGA pictures on 5Mp device (Nexus S) → Camera takes VGA pictures on 5Mp device
This seems not to be reproduceable with the camera-new-features branch.
Assigning it with Wilson (fixed in the camera branch)

Thanks
Hema
blocking-b2g: 1.4? → 1.4+
Assignee: nobody → wilsonpage
Fixed in 'camera-new-features'
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
We should really wait to resolve this until it lands on master for proper tracking.
Flags: needinfo?(wilsonpage)
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(wilsonpage)
Resolution: FIXED → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [branch-camera-new-features fixed]
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [branch-camera-new-features fixed] → [landed-in-master]
Clearing the 1.4+ flag. This was fixed by other bugs in the camera-new-features branch, and the fix, whatever it was, has now been uplifted to master and v1.4.
blocking-b2g: 1.4+ → ---
That actually doesn't have any effect on the blocking decision. Bugs triaged here are triaged independent of how the issue was fixed - it just about whether the issue itself blocks the release or not.
blocking-b2g: --- → 1.4+
Target Milestone: --- → 1.4 S5 (11apr)
You need to log in before you can comment on or make changes to this bug.