Closed Bug 980944 Opened 6 years ago Closed 6 years ago

A lot of Gaia UI tests are failing

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rik, Assigned: emorley)

References

Details

b2g-inbound closed per request in #gaia
This actually did fail on TBPL too but showed up orange 

https://tbpl.mozilla.org/?showall=1&rev=0dc1be930880
Here is the Gu HTML Report:
http://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-central/sha512/685759b961193c83d980453c2daa8847e55fe1bc7b961ddc4d4c03e7c1673d508c208dd0670ff7fb7c9c442b6624ca66d30e0ceb6c3ff61f4819620c41edecad

I ran the tests locally and there's all sorts of weird stuff going on for example the AppWindowManager returning the wrong app as the displayed app (this is the main thing that is disrupting the tests).
Blocks: 974197
Should be fixed by the backout of bug 974197.
Assignee: nobody → emorley
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
It looks like the same tests passed on the OSX desktop builds. Does anyone know of any relevant differences between these two configurations?
(In reply to Matt Woodrow (:mattwoodrow) from comment #6)
> It looks like the same tests passed on the OSX desktop builds. Does anyone
> know of any relevant differences between these two configurations?

When I ran this locally I found the AppWindowManager was reporting odd results like the wrong displayed app.

I'll ni? Alive for you and see if he can help.
Flags: needinfo?(alive)
Hey, I don't see what's wrong here, isn't this fixed by gecko backout?
Flags: needinfo?(alive)
Matt needs help debugging it.
Hm, but I don't know what does "the wrong displayed app" means, any log about this?
I can't get the gaia ui tests to run locally, gaiatest fails with "Timed out waiting for port!".
Ok, managed to get the tests to work using the 'Testing locally with TBPL configuration' section.

But the tests pass locally for me, on ubuntu.
(In reply to Zac C (:zac) from comment #7)
> 
> When I ran this locally I found the AppWindowManager was reporting odd
> results like the wrong displayed app.
> 
> I'll ni? Alive for you and see if he can help.

Can you please walk me through what you had to do to reproduce this locally?

I can't get the tests to fail at all :(
Flags: needinfo?(zcampbell)
1) Download the exact binary that TBPL build (not your self-built one)
2) Build a Gaia profile from a Git gaia clone using "DESKTOP_SHIMS=1 make"
3) The rest is as per MDN and you've got that working already it seems. I would run the browser tests in tests/functional/browser/ directory first.
Flags: needinfo?(zcampbell)
Everything in functional/browser gets skipped because I'm testing on desktop?

Running test_kill.py (one of the ones that failed on tpbl) still passes just fine with the downloaded build.

My patches should only have changed the timing of when the 'MozAfterPaint' event is fired, but I can't find any references to that in gaia.
(In reply to Matt Woodrow (:mattwoodrow) from comment #15)
> Everything in functional/browser gets skipped because I'm testing on desktop?
> 
Yes most tests are for running on real devices, we have to skip them for desktop.

> Running test_kill.py (one of the ones that failed on tpbl) still passes just
> fine with the downloaded build.
> 
> My patches should only have changed the timing of when the 'MozAfterPaint'
> event is fired, but I can't find any references to that in gaia.

I won't have the chance to run this again until Thursday, in the meantime perhaps do another Try run with all suites?
Matt, I ran this again (although on a different computer) and it was passing. I don't know what to try apart from another Try run!
You need to log in before you can comment on or make changes to this bug.