Closed Bug 980989 Opened 8 years ago Closed 8 years ago

sync up changes to sdk/io/buffer.js made in bug 980962

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 986622

People

(Reporter: zombie, Unassigned)

References

Details

see bug 980945.
> this shouldn't be too big of a problem. this issue is:
> 
> a) localized to one module file (plus a unit test)
> b) relatively new, "shipped" less then 3 months ago with SDK 1.15
> a) in a low-level module, with lesser guarantees for stability (marked
> 'experimental')
> c) introduced with SDK 1.15, which (by default) creates addons that use
> modules built into firefox
> 
> so in my estimate, fixing one file and uplifting it to firefox should not
> result in too big compat problems.

https://github.com/mozilla/addon-sdk/blob/master/lib/sdk/io/buffer.js
Blocks: 980945
Depends on: 980962
No longer blocks: 980945
BZ actually did this, we just need sync up..
Summary: remove typed array constructors calls without "new" (per spec) → sync up changes to sdk/io/buffer.js made in bug 980962
Duplicate of this bug: 986346
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986622
You need to log in before you can comment on or make changes to this bug.