Closed Bug 981111 Opened 6 years ago Closed 6 years ago

Text pasted from Word and Pages is available only as text/plain via clipboardData

Categories

(Core :: DOM: Core & HTML, defect)

27 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 586587

People

(Reporter: hello-spam, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

1. On Windows: open MS Word or WordPad. On Mac: open Pages or TextEdit.
2. Write "foo bar baz" in the editor and apply bold to the first word, italic to the second, underline to the third.
3. Copy the text to clipboard.
4. Open http://jsfiddle.net/qG8r7/ and open Developer Tools to see the console.
5. Paste the text from the editor into the editable field on JSFiddle.


Actual results:

In the console output I see that only plain text content is exposed via ClipboardEvent.clipboardData, although formatting is preserved in the pasted content.


Expected results:

text/html data should be available in addition to text/plain.
Duplicate of Bug 850663 and bug 586587
Component: Untriaged → DOM
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586587
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.