Closed Bug 981140 Opened 6 years ago Closed 6 years ago

Add identity.fxaccounts.remote.signup.uri pref for the FxA signup URL

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: ckarlof, Assigned: ckarlof)

References

Details

Attachments

(1 file, 1 obsolete file)

Currently we use identity.fxaccounts.remote.uri, which uses a path of "/". IMO, it's better to be more explicit, because currently "/" doesn't route to any fixed state. The remote client side code makes a decision based on its local state. 

That may be a feature, but it can also lead to bugs. E.g., we are relying on "/" to redirect the user to "/signup". I propose the following:

Add a new pref: "identity.fxaccounts.remote.signup.uri" that maps to "/signup", and leave "identity.fxaccounts.remote.uri" as it is for when we want the page to decide what to show.
Blocks: 956605
Assignee: nobody → ckarlof
Attachment #8389442 - Attachment is obsolete: true
Attachment #8389442 - Flags: review?(mhammond)
Attachment #8389449 - Flags: review?(mhammond)
Blocks: 969593
No longer blocks: 956605
Attachment #8389449 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/mozilla-central/rev/0dd716985cd2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8389449 [details] [diff] [review]
0001-Bug-981140-Make-the-FxA-signup-uri-pref-and-path-exp.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Easier to uplift future patches
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8389449 - Flags: approval-mozilla-aurora?
Attachment #8389449 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.