Closed Bug 981172 Opened 6 years ago Closed 6 years ago

When browserid_identity.js encounters an AuthenticationError it should fire a "weave:service:login:error" notification

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: ckarlof, Assigned: markh)

References

Details

(Keywords: regression, Whiteboard: [qa+])

Attachments

(1 file)

This functionality regressed in Bug 977502.

There are at least two significant listeners of "weave:service:login:error":
 
1) Sync UI, which uses it as a signal to update the "logged in" state
2) The SyncScheduler, which when Status.login enters an "unrecoverable state", like LOGIN_FAILED_LOGIN_REJECTED, then it stops scheduling syncs, which makes sense.

See https://bugzilla.mozilla.org/show_bug.cgi?id=977502#c19 for where it should probably be re-added.
> 2) The SyncScheduler, which when Status.login enters an "unrecoverable state", like LOGIN_FAILED_LOGIN_REJECTED, then it stops scheduling syncs, which makes sense.

http://hg.mozilla.org/mozilla-central/diff/35a1943f351c/services/sync/modules/policies.js#l1.128
Keywords: regression
Whiteboard: [qa+]
Priority: -- → P1
Blocks: 980839
Patch was given r=ckarlof over-the-shoulder while bugzilla was down:

https://hg.mozilla.org/integration/fx-team/rev/dbc54ea4a407
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/dbc54ea4a407
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Sync UI will not be correct
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #8390581 - Flags: review+
Attachment #8390581 - Flags: approval-mozilla-aurora?
Attachment #8390581 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.