500 Internal server error during ABP sync

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: johnp, Assigned: rfkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

After the db schema update in bug 980239 and 980776 the AdblockPlus sync, which previously gave an 404 as described in 980239, now results in a "POST fail 500 Internal Server Error". Complete startup&sync log attached.
Blocks: abp
See Also: → 980239
See Also: → 980776
Assignee: nobody → rfkelly
To guess, I'd say that ABP is triggering some edge-case of the protocol but the actual error is being masked by https://github.com/mozilla-services/mozservices/commit/b539ba083ac2235194ed7570289a7665d07fea15 which turns it into a 5XX rather than a 4XX.  I'll try to reproduce locally.
Unable to reproduce so far, for me adblockplus syncs successfully on both stage and prod environments.

Johannes, do you have any particular settings/configuration of adblockplus that I might try to help reproduce?
Flags: needinfo?(johnp)
Oh, forgot to mention I'm using the latest AdblockPlus Development build.
Didn't try in a clean profile though. Will try that now to be sure nothings magically interfering...
Flags: needinfo?(johnp)
FWIW, reproduced on a clean local profile with the same sync account.
Just checked, the latest development build should be the same as the latest release build according to the ABP dev changelog. Therefore, downloaded the stable 2.5.1 build and got the same error. Checked all modified config entries regarding adblock and sync but found nothing particularly interesting.

One thing I could think of not being very common is Fanboys Ultimate Filter list which weights more than 1MB, but I would think just the link would be synced and not the content:
https://secure.fanboy.co.nz/r/fanboy-ultimate.txt

I'll also attach a .txt with a list of my ABP Filters and a list of preferences from prefs.js containing "adblock" or "sync".
Duplicate of this bug: 981408
Linking server-side deployment bug; I'm hoping this update will turn the 500 error into something a little more useful.
Status: UNCONFIRMED → ASSIGNED
Depends on: 981974
Ever confirmed: true
The server deploy is complete and we fixed some corrupt data in the "collections" table (which is what seemed to be causing the 500 error).  Can you please try syncing adblockplus again?
Flags: needinfo?(johnp)
I can confirm adblockplus sync works now. Thanks for the quick fix.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(johnp)
Resolution: --- → WORKSFORME
Switching to RESOLVED/FIXED because this was a legitimate bug.  Thanks for the report and your patience!
Resolution: WORKSFORME → FIXED
Depends on: 987455
No longer depends on: 987455
You need to log in before you can comment on or make changes to this bug.