Closed Bug 981310 Opened 6 years ago Closed 6 years ago

Displayed error tapping navbar under input element after URL TextSelection

Categories

(Firefox for Metro Graveyard :: App Bar, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 30

People

(Reporter: capella, Assigned: capella)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Attached patch bug973925.diffSplinter Review
Splitting this off bug 973925 since it's reproducable and fixable.

STR:
1) Open any page such as www.google.com
2) Swipe up from bottom to expose navbar and tabs-bar
3) Touch-tap into the url to selectALL and pop open the soft keyboard
   https://www.dropbox.com/s/hhxcodu4qjpz4o9/Screenshot%20%2817%29.png
4) Touch-tap in the margin below the input field and above the keyboard
5) Navbar drops down, keyboard stays open, monocles stay on-screen
   https://www.dropbox.com/s/1jps29jwbomzoho/bug973925%20two%20float.png

This timing was a little tricky to figure out, but this patch fixs the problem. Writing an automated test to prove the patch is a little more tricky, and while I'm poking @ it, I thought I'd post the fix for consideration.

( Maybe you can see a better solution :-D )

I thought to test by software tapping and checking for monocle position / rect margins, but it appears that automated keyboard behavior isn't duplicated in the test suite. 

Still thinking ...
Attachment #8388095 - Flags: review?(jmathies)
I can't reproduce this bug. If I click a little to the left I get one of the nav buttons. Tapping under the nav bar edit seems impossible and generally focus remains in the nav bar edit. Is there some sort of common user case here that I'm missing?
Not easy-easy to repro, but not hard after a little practice ...

https://www.dropbox.com/s/yb6a0vv66myp45u/bug981310.mp4
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
Comment on attachment 8388095 [details] [diff] [review]
bug973925.diff

I was never really able to reproduce this reliably, but I also didn't see any negative side effects from these changes. r+ based on that.
Attachment #8388095 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/58aaf5762a1b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.