Add a whitelist for mixed content blocking

VERIFIED DUPLICATE of bug 873349

Status

()

defect
VERIFIED DUPLICATE of bug 873349
5 years ago
4 years ago

People

(Reporter: lists, Unassigned)

Tracking

27 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
This is basically a clone of bug 873349, which is set to WONTFIX but I cannot re-open the bug, as it's clearly not resolved and no technical reason was given why the bug was set to WONTFIX. Original description:

========================================
Steps to reproduce:

I'm loading pages with mixed content.

gecko.mstone = 23.0a2
gecko.buildID = 20130514004016

Actual results:

The mixed content is blocked, even if on past occasions I had unblocked it. That may be what is intended:
tvyas wrote on May 16th, 2013 at 6:13 am:

We don’t have a whitelist mechanism. Mixed Content is blocked on a per-page load basis. “Disabling Protection” and allowing the content is hence also per-page load.

Expected results:

Feature request: The mixed content should remain unblocked, or there should be a whitelist or something similar. It's a nuisance to have to unblock the content on each load. Thanks
========================================

As many people pointed out in bug 873349, a whitelist mechanism is needed. Quoing myself:


We're using Firefox in a corporate intranet and lots of sites offer https/http mixed content. While in an ideal world, this should not happen, the reality cannot be changed short term. Having some kind of whitelist (e.g. "Always allow mixed content on this site") would be very helpful indeed.

Also, I don't see how one user can close this as WONTFIX when so many people clearly need more flexibility here. As so often, security is not a binary choice. Please reconsider.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873349
You need to log in before you can comment on or make changes to this bug.