Closed Bug 981361 Opened 6 years ago Closed 6 years ago

Intermittent tests/test-functional.test throttle | function called again during second throttle period - 3 == 2

Categories

(Add-on SDK Graveyard :: General, defect, P1)

x86
Windows 8
defect

Tracking

(firefox29 unaffected, firefox30 fixed, firefox31 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- unaffected
firefox30 --- fixed
firefox31 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: philor, Assigned: jsantell)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=35852189&tree=Mozilla-Central
WINNT 6.2 mozilla-central pgo test jetpack on 2014-03-08 20:49:19 PST for push 21f293fc8d34
slave: t-w864-ix-077

TEST-START | tests/test-functional.test throttle
TEST-PASS | tests/test-functional.test throttle | function called atleast once during first throttle period
TEST-PASS | tests/test-functional.test throttle | function attempted to be called several times during first period
TEST-UNEXPECTED-FAIL | tests/test-functional.test throttle | function called again during second throttle period - 3 == 2
TEST-INFO | Traceback (most recent call last):
  File "resource://gre/modules/commonjs/sdk/timers.js", line 40, in notify
    callback.apply(null, args);
  File "resource://extensions.modules.7e47b831-eea4-4563-9d03-e709d614afd3-at-jetpack.commonjs.path.tests/test-functional.js", line 456, in exports["test throttle"]/<
    assert.equal(called, 3, "function called again during second throttle period");
  File "resource://gre/modules/commonjs/sdk/test/assert.js", line 124, in equal
    operator: "=="
  File "resource://gre/modules/commonjs/sdk/test/assert.js", line 88, in fail
    this._log.fail(message);
  File "resource://gre/modules/commonjs/sdk/deprecated/unit-test.js", line 83, in fail
    this.console.testMessage(false, false, this.test.name, message);
  File "resource://gre/modules/commonjs/sdk/test/harness.js", line 527, in testMessage
    this.trace();
TEST-PASS | tests/test-functional.test throttle | function attempted to be called several times during second period
TEST-END | tests/test-functional.test throttle
Duplicate of this bug: 981633
Assignee: nobody → jsantell
Priority: -- → P1
Attachment #8390698 - Flags: review?(dtownsend+bugmail)
Attachment #8390698 - Flags: review?(dtownsend+bugmail) → review-
Attachment #8390698 - Flags: review- → review?(dtownsend+bugmail)
Attachment #8390698 - Flags: review?(dtownsend+bugmail) → review+
Sorry for taking the review Dave, Jordan asked me to.
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/615924c924c1996e134dba4cb229b8fd447fe8ef
Bug 981361 Fix intermittent timing failures for throttle tests

https://github.com/mozilla/addon-sdk/commit/ade4f99c2bf61e58dfbfafd9fe1b1b3c153dc9c7
Merge pull request #1433 from jsantell/981361-fix-throttle-tests-part2

Bug 981361 Fix intermittent timing failures for throttle tests
Looks like bug 985956 has fixed this. Good job Jordan
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Dave Townsend (:Mossop) from comment #236)
> Looks like bug 985956 has fixed this. Good job Jordan

Can we get this fix uplifted to Aurora as well please? :)
Flags: needinfo?(jsantell)
Pinging Erik and Wes about uplifting, not sure who can do that
Flags: needinfo?(kwierso)
Flags: needinfo?(jsantell)
Flags: needinfo?(evold)
Steps to uplift this would be to do this:
git checkout firefox30
git cherry-pick 615924c924c1996e134dba4cb229b8fd447fe8ef
[assuming that applies cleanly]
git push origin firefox30

Once that's pushed, you'd follow the normal SDK uplift procedure, but you'd be pushing the firefox30 branch into mozilla-aurora, instead of firefox31 into mozilla-central.
Flags: needinfo?(kwierso)
(In reply to Wes Kocher (:KWierso) from comment #240)
> Steps to uplift this would be to do this:
> git checkout firefox30
> git cherry-pick 615924c924c1996e134dba4cb229b8fd447fe8ef
> [assuming that applies cleanly]
> git push origin firefox30
> 
> Once that's pushed, you'd follow the normal SDK uplift procedure, but you'd
> be pushing the firefox30 branch into mozilla-aurora, instead of firefox31
> into mozilla-central.

Forgot to add, that you'll need to attach a patch here and set the approval‑mozilla‑aurora flag on the patch to "?" and fill in the prompted questions about why it should be uplifted. This should probably be a patch for mercurial and not git, though I suppose requesting the approval on the pull request attachment would be okay.
Thanks Ryan!
You need to log in before you can comment on or make changes to this bug.