Closed Bug 981538 Opened 6 years ago Closed 6 years ago

[Errno 32] Broken pipe: Connection to Marionette server is lost.

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 981202

People

(Reporter: askeing, Unassigned)

Details

Attachments

(1 file)

The gaiatest cannot finish all functional tests (--type=b2g gaiatest/tests/functional/manifest.ini --restart --timeout=30000).
It will raise the broken pipe error.

### ENV
Buri
Gaia      6c109df47006b08c082761c0ddd6ba53a864983a
Gecko     https://hg.mozilla.org/mozilla-central/rev/21f293fc8d34
BuildID   20140309160201
Version   30.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013

### Error Message
Traceback (most recent call last):
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/bin/gaiatest", line 9, in <module>
    load_entry_point('gaiatest==0.21.8', 'console_scripts', 'gaiatest')()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/runtests.py", line 49, in main
    cli(runner_class=GaiaTestRunner, parser_class=GaiaTestOptions)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runtests.py", line 28, in cli
    runner = startTestRunner(runner_class, options, tests)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runtests.py", line 19, in startTestRunner
    runner.run_tests(tests)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runner/base.py", line 761, in run_tests
    self.run_test_sets()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runner/base.py", line 958, in run_test_sets
    self.run_test_set(in_process_tests)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runner/base.py", line 949, in run_test_set
    self.run_test(test['filepath'], test['expected'], test['oop'])
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runner/base.py", line 928, in run_test
    results = runner.run(suite)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/runner/base.py", line 284, in run
    test(result)
  File "/usr/lib/python2.7/unittest/suite.py", line 70, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib/python2.7/unittest/case.py", line 391, in __call__
    return self.run(*args, **kwds)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 200, in run
    self.cleanTest()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 279, in cleanTest
    self._deleteSession()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette_test.py", line 291, in _deleteSession
    self.marionette.delete_session()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 741, in delete_session
    response = self._send_message('deleteSession', 'ok')
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/marionette.py", line 598, in _send_message
    response = self.client.send(message)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.5-py2.7.egg/marionette/client.py", line 97, in send
    raise IOError("%s: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors." % str(e))
IOError: [Errno 32] Broken pipe: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.
Attached file fail.log
Looks like it's crashing when we see this in logcat:

E/        (24027): Error Loading libmpqstobinder 
E/        (24027): Error: Cannot load library: load_library[1091]: Library 'libmpqstobinder.so' not found
E/GestureDeviceService(24027): Could not load gesture HAL module


Is there a specific test that is generating this error?
Flags: needinfo?(fyen)
Looks like we found the main bug for this issue:

https://bugzilla.mozilla.org/show_bug.cgi?id=981202
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 981202
You need to log in before you can comment on or make changes to this bug.