Open Bug 98157 Opened 19 years ago Updated 12 years ago

Caret does not have bidi marker in certain dialog boxes

Categories

(Core :: Layout: Text and Fonts, defect)

x86
All
defect
Not set

Tracking

()

People

(Reporter: xslf, Assigned: zwnj)

References

(Blocks 2 open bugs, )

Details

Attachments

(3 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010831
BuildID:    2001083103

In certain dialog boxes, like "file bookmark" and "find in this page", the caret
does not have a bidi marker, making it diffcult to tell the corect language
/directionlity

Reproducible: Always
Steps to Reproduce:
1. Open any URL
2. Go to Search--> Find in this page.
3. Observe the caret in the db

1. Open any URL
2. Go to Bookmarks--> File bookmark
3. Observe the caret in the db


Actual Results:  In both cases, the caret does not have a bidi marker.

Expected Results:  Caret should have Bidi marker

This happends both on win98 and win2000 (both are hebrew enbaled).
The blown-up screent shots that I am attching show that the marker is just not
there, not even in a 1 pixle size.
Summary: Caret does not have bidi marker in certain dilog boxes → Caret does not have bidi marker in certain dialog boxes
Attached image The find db on win98
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Accidentally marked WFM, reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Blocks: 115711
just tested in windows 2000/ build id 2002032003: still broken
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Workaround:
Switch the language once.
The caret should then display the correct input direction.

Tested with Mozilla 1.2b (2002101612) under Windows XP.
This problem happens with the latest Phoenix and Beonex as well.

Prog.

Blocks: BidiCaret
Blocks: Persian
The problem is nsIBidiKeyboard doesn't check all keyboard layouts on initialization.  We are going to fix it on trunk now.
Assignee: mozilla → behnam
QA Contact: zach → smontagu
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: smontagu → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.