Closed Bug 981621 Opened 6 years ago Closed 6 years ago

crash in mozilla::gfx::DrawTargetSkia::InitWithGrContext(GrContext*, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::SurfaceFormat)

Categories

(Firefox for Android :: Toolbar, defect, critical)

30 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- unaffected
firefox30 + fixed
firefox31 + fixed

People

(Reporter: aaronmt, Assigned: snorp)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-337b97f5-9376-4858-80e4-7c0d12140309.
=============================================================
Assignee: nobody → snorp
This crash recently became a frequent cause of test failures on the Android x86 emulator (in tests run only on Cedar/Ash). https://tbpl.mozilla.org/php/getParsedLog.php?id=35889666&tree=Ash&full=1
Attachment #8388533 - Flags: review?(gwright) → review+
We should look into why GrContext creation is failing though.
See Also: → 986330
Duplicate of this bug: 986330
This is a regression in Firefox 30 according to the signature in comment 0.
https://hg.mozilla.org/mozilla-central/rev/19c385644075
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Oops, this still crashes because the skia texture can be null (if it's too large, etc).
Yeah, my Android x86 crashes continue: https://tbpl.mozilla.org/php/getParsedLog.php?id=36645054&tree=Ash&full=1#error0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Creating the texture can fail if it's too big, or something, so we need to guard against that here too.
Attachment #8396384 - Flags: review?(gwright)
Comment on attachment 8396384 [details] [diff] [review]
Don't crash if we fail to create SkiaGL backing texture

Review of attachment 8396384 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #8396384 - Flags: review?(gwright) → review+
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #10)
> Created attachment 8396384 [details] [diff] [review]
> Don't crash if we fail to create SkiaGL backing texture

Looks good on Ash: https://tbpl.mozilla.org/?tree=Ash&rev=5d611ee724de

(There is a shutdown hang in M2, but I assume that is not related.)
https://hg.mozilla.org/mozilla-central/rev/cf6adb086a9e
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Looks like we need an aurora uplift nomination here if this is a low risk landing so we don't ship this crash.
Comment on attachment 8396384 [details] [diff] [review]
Don't crash if we fail to create SkiaGL backing texture

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 939276
User impact if declined: crashes with large <canvas>
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8396384 - Flags: approval-mozilla-aurora?
Attachment #8396384 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Ed Morley [:edmorley UTC+0] from comment #14)
> Push backed out:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?changeset=b9f2eb47b6f5

Was this backout pushed to m-c as well? If so, this bug is not really fixed, or is it?
Flags: needinfo?(snorp)
(In reply to Mark Finkle (:mfinkle) from comment #18)
> (In reply to Ed Morley [:edmorley UTC+0] from comment #14)
> > Push backed out:
> > https://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?changeset=b9f2eb47b6f5
> 
> Was this backout pushed to m-c as well? If so, this bug is not really fixed,
> or is it?

Yeah, it's in.
Flags: needinfo?(snorp)
You need to log in before you can comment on or make changes to this bug.