Closed Bug 981764 Opened 7 years ago Closed 7 years ago

[Task manager] Homescreen artifact during downscale animation

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: diego, Assigned: aus)

References

()

Details

(Whiteboard: [caf priority: p2][CR 623398][systemsfe][p=1])

Attachments

(2 files)

STR:

1. Open contacts app
2. Open settings app
3. Long press home to open task manager
4. Observe upscaled portion homescreen flash in the background during downscale animation.
Duplicate of this bug: 981766
Duplicate of this bug: 981782
Attached file Screen recording
This issue is reproducible on QRD 8x26.

@alive any idea what's going on?
Flags: needinfo?(alive)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Might be cards view (task manager issue) because the black overlay should appear soon before seeing homescreen opening animation.

I don't see this in my unagi though :/
Flags: needinfo?(alive) → needinfo?(aus)
It seems this is not reproducible on ICS based devices like Unagi. I reproduced it on a kitkat device. It may also be reproducible on a Jellybean device like nexus 4.
Whiteboard: [CR 623398]
When we go to the cards view, we actually go to the homescreen first, then show the cards view. The cards view dom elements required for it to function are all in the homescreen / system application so there is no way around this right now. We could possibly ensure that the homescreen / system application has the black overlay enabled before we transition to it... not sure if that will solve the problem though.

Alive, what do you think?
Flags: needinfo?(aus) → needinfo?(alive)
Works for me, just call homescreenWindow.fadeoOut and homescreenWindow.fadeIn when cardsView is shown / hidden.
Flags: needinfo?(alive)
Assignee: nobody → aus
Whiteboard: [CR 623398] → [CR 623398][systemsfe][p=1]
Target Milestone: --- → 1.4 S4 (28mar)
Status: NEW → ASSIGNED
This wasn't a problem in v1.3 on the same device. Any idea what changed?
Flags: needinfo?(aus)
blocking-b2g: --- → 1.4?
Gregor,

Can you please help with fixing this on 3/21?

Is it possible?
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(anygregor)
:diego, many things have changed around window management, any of them could be causing this.

:preeti, it's already assigned and should land within this spring which ends 3/28, I can't guarantee it for the 21st.
Flags: needinfo?(aus)
Flags: needinfo?(anygregor)
apologies for the typo, that should read "sprint" not "spring".
Whiteboard: [CR 623398][systemsfe][p=1] → [CR 623398][systemsfe][p=1][systemsfe]
Whiteboard: [CR 623398][systemsfe][p=1][systemsfe] → [CR 623398][systemsfe][p=1]
:aus, are you still working on this bug?
Flags: needinfo?(aus)
Yep, I'm stuck on another bug so I'm going to be taking care of this today.
Flags: needinfo?(aus)
Aus,

Do you think we can have a patch for this one by 3/27? Please let me know
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Unknown
[User impact] if declined: Annoying nagging animation glitch
[Testing completed]: Unit tests, Integration Tests pass, Manually tested on a Keon as well.
[Risk to taking this patch] (and alternatives if risky): Low to no risk.
[String changes made]: None.
Attachment #8396797 - Flags: review?(alive)
Attachment #8396797 - Flags: approval-gaia-v1.4?(fabrice)
Attachment #8396797 - Flags: approval-gaia-v1.4?(fabrice) → approval-gaia-v1.4?(release-mgmt)
Comment on attachment 8396797 [details] [review]
Pull Request - Added 'cardviewbeforeshow' and 'cardviewbeforeclose'. Made HomescreenLauncher use those new events to fadeOut/fadeIn the Homescreen instance when appropriate.

No need for approval. it's already 1.4+
Attachment #8396797 - Flags: approval-gaia-v1.4?(release-mgmt)
Neat side effect, it feels more responsive. :)
Comment on attachment 8396797 [details] [review]
Pull Request - Added 'cardviewbeforeshow' and 'cardviewbeforeclose'. Made HomescreenLauncher use those new events to fadeOut/fadeIn the Homescreen instance when appropriate.

See github comments
Attachment #8396797 - Flags: review?(alive)
Attachment #8396797 - Attachment description: Pull Request - fadeOut/fadeIn homescreen on cards view show/hide → Pull Request - Added 'cardviewbeforeshow' and 'cardviewbeforeclose'. Made HomescreenLauncher use those new events to fadeOut/fadeIn the Homescreen instance when appropriate.
Attachment #8396797 - Flags: review?(alive)
I cherry picked https://github.com/mozilla-b2g/gaia/pull/17607 to v1.4 and it works for me. Thanks Ghislain!
Attachment #8396797 - Flags: review?(alive) → review+
Fixed on master.

Commit: https://github.com/mozilla-b2g/gaia/commit/6c4c90e31dc523e5d204035daeea3b422f5fc24d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This has conflicts on v1.4.
Flags: needinfo?(aus)
I'll have a patch for 1.4 tomorrow.
Flags: needinfo?(aus)
1.4 merge is green. We're all done with this one. :)
Whiteboard: [CR 623398][systemsfe][p=1] → [caf priority: p2][CR 623398][systemsfe][p=1]
Flags: in-moztrap?(bzumwalt)
New test case needs to be written to address bug.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Test case added in moztrap:

https://moztrap.mozilla.org/manage/case/14357/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(bzumwalt)
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.