Closed Bug 981849 Opened 6 years ago Closed 6 years ago

Border of dropdown arrow of <select> is missing when state is hover, active, focus

Categories

(Core :: Layout: Form Controls, defect)

30 Branch
All
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox30 + verified
firefox31 --- verified

People

(Reporter: alice0775, Assigned: alexhenrie24)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

Attached file testcase
STR
1. Mouse over
2. Click
3. Moseout


Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/39523a8931d5
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140307054957
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e8afab50c7fe
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140307055457
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=39523a8931d5&tochange=e8afab50c7fe

Regressed by:
	cfbcdc591ccd	Alex Henrie — Bug 963970 - Place combobox button where a scrollbar would be. r=roc
Attached image screenshot
The bug is labeled "Windows 8.1", but I see the problem on Windows 7 as well (but not Ubuntu).
Attached patch Proposed patchSplinter Review
Try this and tell me if it breaks anything else.
Assignee: nobody → alexhenrie24
Status: NEW → ASSIGNED
Attachment #8388953 - Flags: review?(roc)
I'm cc'ing the people from bug 420381 in case they have a better idea of what's going on.
Hardware: x86_64 → All
Does this patch really work? I don't have Windows here.

We probably need to uncomment the #if 0 code in GetWidgetOverflow.
The code in GetWidgetOverflow doesn't compile. I get "error C2227: left of '->Inflate' must point to class/struct/union/generic type"
I messed up the try syntax. Trying again: https://tbpl.mozilla.org/?tree=Try&rev=e02545287f93
Comment on attachment 8388953 [details] [diff] [review]
Proposed patch

Review of attachment 8388953 [details] [diff] [review]:
-----------------------------------------------------------------

I tested it and it seems to work fine. Let's land this.
Attachment #8388953 - Flags: review?(roc) → review+
Requesting checkin of attachment 8388953 [details] [diff] [review]
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/96ddf36f6657
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Works for me. Thanks!

Sebastian
Depends on: 995181
Keywords: verifyme
Reproduced in Nightly 2014-03-11.
Verified fixed 31.0a1 (2014-04-28) Win 7 x64.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Beta uplift nomination please, if this is low risk enough to consider
Flags: needinfo?(alexhenrie24)
I'll feel more comfortable about uplifting after bug 995181 is resolved.
Flags: needinfo?(alexhenrie24)
Bug 995181 isn't a tracked issue and has no assignee.  This bug is more visible and is verified on FF31 so I don't see why we would block on landing this for the other bug to be resolved.  I'd like to get this into this week's betas in order to get the user feedback.
Flags: needinfo?(roc)
I agree, let's put this on beta.
Flags: needinfo?(roc)
Comment on attachment 8388953 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 963970
User impact if declined: visual regression on drop-down buttons
Testing completed (on m-c, etc.): been on trunk a while with only one small regression found
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none
Attachment #8388953 - Flags: approval-mozilla-beta?
Attachment #8388953 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8388953 [details] [diff] [review]
Proposed patch

Sorry, I should have requested Aurora approval at the same time.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 963970
User impact if declined: visual regression on drop-down buttons
Testing completed (on m-c, etc.): been on trunk a while with only one small regression found
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none
Attachment #8388953 - Flags: approval-mozilla-aurora?
Robert, Looking at comment #14, it seems already fixed+verified?!
Flags: needinfo?(roc)
Why do you request an uplift to aurora (31) then?!
Verified as fixed on Firefox 30 beta 8 (20140527133511) under Win 7 64-bit and Win 8.1 32-bit.
Comment on attachment 8388953 [details] [diff] [review]
Proposed patch

According to comment 14, there is no need to uplift to Aurora as the fix landed on 31 (currently Aurora) while on Nightly.
Attachment #8388953 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
You need to log in before you can comment on or make changes to this bug.