Closed Bug 981948 Opened 7 years ago Closed 7 years ago

[Tarako][DSDS]Update Radiocontrol for power consumption

Categories

(Firefox OS Graveyard :: Vendcom, defect)

defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g -

People

(Reporter: sam.hua, Assigned: sam.hua)

References

Details

(Keywords: perf, Whiteboard: [c=power p= s=2014.03.28 u=] [POVB])

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

1 Don't insert SIM
2 power on and measure the power consumption 



Actual results:

1 it is much higher than the android phone(Tarako device) 
2 it is much higher than the fly mode(Tarako device) 


Expected results:

It should be almost same with fly mode
In the android, it don't open the RADIO when no SIM,But it will open the RADIO when dialing 112. and then it will close it when 112 ended.
Component: General → RIL
Flags: needinfo?(htsai)
(In reply to sam.hua from comment #1)
> In the android, it don't open the RADIO when no SIM,

Is this only on Tarako android?

> But it will open the
> RADIO when dialing 112. and then it will close it when 112 ended.

I think this is very UX-dependent. For example, my android phone won't turn on airplane mode automatically after I dial 112 on airplane mode.
Flags: needinfo?(htsai)
Sorry, what does the UX-dependent mean?

Yes, only Tarako.

We need to reduce the power consumption when no sim card. it is an important case in our QA test.
(In reply to sam.hua from comment #3)
> Sorry, what does the UX-dependent mean?
> 
> Yes, only Tarako.
> 
> We need to reduce the power consumption when no sim card. it is an important
> case in our QA test.
Sam,  like what Hsinyi said, it is UX-dependent, and also it's not just a simple modification for gaia and gecko. We need to change the original scenario, notify user that change, and consider the exceptions. Because the schedule is tight and these modifications on Gecko and Gaia need a lot of discussion with each other team, I wonder if you can fix this in rilc and rilc don't need to let gecko and gaia be aware of this special change.

Steven, could you also please discuss this with sam?
Flags: needinfo?(slee)
Flags: needinfo?(sam.hua)
(In reply to Ken Chang[:ken] from comment #4)
> Steven, could you also please discuss this with sam?
Ken, I think you want another Steven.
Flags: needinfo?(slee)
okay,i add james
Flags: needinfo?(sam.hua) → needinfo?(james.zhang)
Our android open/close radio in frameworks. I think we need not add some code in gaia. Maybe add some code in gecko.
Sam, can you give me the android code for no sim card power consume.
Flags: needinfo?(ttsai)
Flags: needinfo?(styang)
Flags: needinfo?(james.zhang)
For me, it's most likely a platform-dependent issue. It makes more sense to handle it on vendor builds.
Flags: needinfo?(styang)
Agree with Steven. No matter whether SIM is inserted or not, it should not effect power consumption.
Component: RIL → Vendcom
Add Bruce, please check this power consumption issue, can modem disable radio without sim card and enable radio when 112 dialing?
I think it should be controlled in Gecko.just like dialing 112 in airplane mode.
(In reply to sam.hua from comment #11)
> I think it should be controlled in Gecko.just like dialing 112 in airplane
> mode.
For us, it is a very special cases. How do users get the emergency cell broadcast message(Earthquake and tsunami alerting message) if we automatically turn off flight mode?
By the way, can you please share power consumptions for both flight mode and no-sim mode?
James, Sam : To disable modem power without sim is very project specific feature, can you try your own patch?
Flags: needinfo?(ttsai)
Hi Ken,
Power consumption of 
6821 FFOS:
  airplane mode: 1mA
  no SIM       : 3.7mA
6821 Spreadtrum Android
  airplane mode: 1mA
  no SIM       : 1mA
Note: Emergency number is not just 112, it is 911 in US; different other numbers in other countries.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 963391
Blocks: 978485
blocking-b2g: --- → 1.3T?
it seems very platform specific, can your team fix it on your side? 
we need our OS to be platform neutral. thanks
blocking-b2g: 1.3T? → -
Flags: needinfo?(james.zhang)
Whiteboard: [POVB]
OK,it's our issue.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Sam, please check power consumption with reference phone first.
Status: RESOLVED → REOPENED
Flags: needinfo?(james.zhang)
Resolution: INVALID → ---
Assignee: nobody → sam.hua
it won't be fixed. 
When no SIM, it should be emergency mode instead of airplane mode
Flags: needinfo?(james.zhang)
Fixed.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(james.zhang)
Resolution: --- → FIXED
Keywords: perf
Whiteboard: [POVB] → [c=power p= s=2014.03.28 u=] [POVB]
Target Milestone: --- → 1.4 S4 (28mar)
You need to log in before you can comment on or make changes to this bug.