Closed Bug 981957 Opened 6 years ago Closed 6 years ago

Make browserid_identity's log consistent with other sync logs

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: markh, Assigned: markh)

Details

Attachments

(1 file)

We want "debug" log messages from browserid_identity to appear in the sync logs to be consistent with the other sync logs.  Also, we want a to be able to flip a single pref and see all log messages dumped to the console.

This means:

* Remove the DumpAppender from browserid_identity.
* Add a default pref to set the log level to Debug.

Then the initLogs function in policies.js will do the right thing and ensure all log output is written to the sync logs.

IMO we want this in 29 so errors reported in the field have debug bid_identity logs.
Simple patch:
* default the log level to "Debug"
* don't create a separate DumpAppender
Assignee: nobody → mhammond
Attachment #8388947 - Flags: review?(rnewman)
Attachment #8388947 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/f25fb5db8893
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8388947 [details] [diff] [review]
0001-Bug-981957-make-browserid_identity-s-logs-consistent.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Sync logs submitted by users may not have all relevant data
Testing completed (on m-c, etc.): m-c 
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8388947 - Flags: approval-mozilla-aurora?
Attachment #8388947 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.