Closed Bug 982033 Opened 7 years ago Closed 7 years ago

[bubble-tea] change layout manager instantiate place to solve app_window dependency

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S4 (28mar)

People

(Reporter: gasolin, Assigned: gasolin)

Details

(Whiteboard: [in-bubble-tea])

Attachments

(2 files)

according to https://travis-ci.org/mozilla-b2g/gaia/builds/20511534

we met loading sequence issue, layout_manager.js is loaded after app_window.js, but is needed for app_window.js.
Assignee: nobody → gasolin
Summary: change layout manager instantiate place to solve app_window dependency → [bubble-tea] change layout manager instantiate place to solve app_window dependency
Attached file commit on github
need to use merge PR to reproduce this issue https://github.com/mozilla-b2g/gaia/pull/17063
Attachment #8389082 - Flags: review?(alive)
Attachment #8389082 - Flags: review?(alive) → review+
Attached file master PR#17692
merged https://github.com/mozilla-b2g/gaia/commit/3b4ee98f309fecfa2b5b9902cfa4fe68db1eba2c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Ok, the problem is that https://github.com/mozilla-b2g/gaia/commit/d84935863b56ea76d7d33486f44a64467a70885f did not correctly revert the original changes to bootstrap.js which are located here: https://github.com/mozilla-b2g/gaia/commit/8d89fc1c523e46e7ff6ec45687605c7b60f91a34#diff-8831155d38305fdad64644f0aa3eed8bR84.

I have landed a follow-up revert here, which should hopefully resolve the TBPL issues: https://github.com/mozilla-b2g/gaia/commit/d65d0f7fa9cda0a41b98149e3c540a41eb27b11f.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/58a16738c92f
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S4 (28mar)
The Gaia pull request (attachment 8397671 [details] [review]) was partially reverted by https://github.com/mozilla-b2g/gaia/commit/2a6aaa71e1dc39343dce115d005a6bd61a916591 .  This makes emulator always boots in airplane mode.
Status: RESOLVED → REOPENED
Flags: needinfo?(ryanvm)
Flags: needinfo?(gasolin)
Resolution: FIXED → ---
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> The Gaia pull request (attachment 8397671 [details] [review]) was partially reverted
> by
> https://github.com/mozilla-b2g/gaia/commit/
> 2a6aaa71e1dc39343dce115d005a6bd61a916591 .  This makes emulator always boots
> in airplane mode.

Update Gecko to m-c tip resolves this issue.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(ryanvm)
Flags: needinfo?(gasolin)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.