Closed Bug 982113 Opened 8 years ago Closed 8 years ago

Blank white box above keyboard when keyboard is opened from partially visible input field

Categories

(Core :: Panning and Zooming, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: zcampbell, Unassigned)

Details

(Keywords: qablocker, regression, Whiteboard: [xfail])

Attachments

(1 file)

Attached image 2014-03-11-14-58-25.png
STR:

1. Open Contacts app and open a new contact.
2. Scroll the page so that the "Comments" field is half on the screen and half off the screen.
3. Tap in the input field
4. The keyboard will open but a white panel will obscure some of the contacts app (see screenshot). You can see the white panel flicker.

Testing build:
Device Hamachi
Gaia      a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko     https://hg.mozilla.org/mozilla-central/rev/41d962d23e81
BuildID   20140311040203
Version   30.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013

This first started failing in the Monday nightly build but I am going to try and get a more accurate regression range.
Might be a tiling regression. Can we confirm this doesn't reproduce on 1.3?
Keywords: qawanted, regression
This issue doesn't reproduce on the latest Buri Master M-C build when APZ is disabled. When APZ is enabled, the white panel appeared 100% of the time following the STR from comment 0. I was not able to reproduce this issue using the latest Buri v1.3 build. 

Environmental Variables:
Device: Buri v1.3 mozRIL
BuildID: 20140311004003
Gaia: 6b1180917fa4af4e4b7e31b51fc06a4bbaa2ad0f
Gecko: 8976860941f2
Version: 28.0
v1.2-device.cfg
Keywords: qawanted
blocking-b2g: --- → 1.4?
Component: Gaia::Keyboard → Panning and Zooming
Product: Firefox OS → Core
Version: unspecified → Trunk
Whiteboard: [xfail]
Keywords: qablocker
QA Contact: bzumwalt
Issue does not occur on latest Nightly 1.4 Master build.

Result: No graphical issues when keyboard is opened on partially visible new contact comment input field

1.4 Environmental Variables:
Device: Buri v1.4 Master Mozilla RIL
BuildID: 20140312040203
Gaia: 3005269d4dcabcc7d27eaf72bda44a969873af8c
Gecko: 23005b395ae8
Version: 30.0a1
Firmware Version: v1.2-device.cfg


Ran Reverse Regression-Window to see what commit resolved issue. Results below:

Last Broken Build:
Environmental Variables:
Device: Buri v1.4 ENG Mozilla-Inbound
BuildID: 20140310192240
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: cafc246cc62c
Version: 30.0a1
Firmware Version: v1.2-device.cfg


First Working Build:
Environmental Variables:
Device: Buri v1.4 ENG Mozilla-Inbound
BuildID: 20140310204542
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: c234a1aeaeab
Version: 30.0a1
Firmware Version: v1.2-device.cfg


Tinderbox Gecko/Gaia Swap Results:

Last Working Gaia/Last Broken Gecko: Issue DOES Reproduce
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 41d962d23e81

First Broken Gaia/First Working Gecko: Issue Does NOT Reproduce
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 9cdaf3f7c601

Appears to be Gecko issue.

Mozilla-Inbound Push Log: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cafc246cc62c&tochange=c234a1aeaeab
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.