Bookmarks toolbar shrinks in size when Bookmarks Toolbar Items is moved out of the Bookmarks toolbar in customization mode

RESOLVED FIXED in Firefox 30

Status

()

defect
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: mikedeboer, Assigned: Gijs)

Tracking

(Blocks 1 bug)

Trunk
Firefox 31
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-qa-testsuite ?
in-testsuite -

Firefox Tracking Flags

(firefox29 wontfix, firefox30 fixed, firefox31 fixed)

Details

(Whiteboard: [Australis:P3-])

Attachments

(1 attachment)

STR:

1. Make sure the Bookmarks toolbar is visible
1. Open Customize Mode on OSX nightly
2. Drag the Bookmarks toolbar placeholder button to the nav-bar

Resulting issues that can be seen:
1. The toolbar height jumps to a smaller size when the placeholder is dragged out of it
2. When placed in the nav-bar, the placeholder causes all other toolbar items to be mis-aligned.
Wouldn't this be fixed by fixing bug 734326 ?
(In reply to Guillaume C. [:ge3k0s] from comment #1)
> Wouldn't this be fixed by fixing bug 734326 ?

No, the placeholder button already has different styling than bookmark items. The problem is that the button inside Customize Mode is misbehaving.
(In reply to Mike de Boer [:mikedeboer] from comment #0)
> STR:
> 
> 1. Make sure the Bookmarks toolbar is visible
> 1. Open Customize Mode on OSX nightly
> 2. Drag the Bookmarks toolbar placeholder button to the nav-bar
> 
> Resulting issues that can be seen:
> 1. The toolbar height jumps to a smaller size when the placeholder is
> dragged out of it
> 2. When placed in the nav-bar, the placeholder causes all other toolbar
> items to be mis-aligned.

(2) is filed separately already: bug 923156
Duplicate of this bug: 982208
Summary: Bookmarks toolbar placeholder issues in customize mode → Bookmarks toolbar shrinks in size when Bookmarks Toolbar Items is moved out of the Bookmarks toolbar in customization mode
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
The 19px change is simply reflecting reality - the bookmarks buttons in the navbar are already 18px with a 1px bottom border. The other min-height is new and fixes the issue at hand.
Attachment #8406220 - Flags: review?(mdeboer)
Comment on attachment 8406220 [details] [diff] [review]
bookmarks toolbar shrinks when removing the bookmarks toolbar items,

Review of attachment 8406220 [details] [diff] [review]:
-----------------------------------------------------------------

This does fix the issue at hand.

I'm still unhappy about the state we get in when you drag the Personal Toolbar Items on the nav-bar or TabsToolbar... but that has _nothing_ to do with this bug :)

Most importantly, this patch doesn't regress it further.
Attachment #8406220 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/57f2b31da569
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/57f2b31da569
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8406220 [details] [diff] [review]
bookmarks toolbar shrinks when removing the bookmarks toolbar items,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a (existed pre-Australis, too)
User impact if declined: toolbar changes size if you remove items off it
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, CSS-only
String or IDL/UUID changes made by this patch: none
Attachment #8406220 - Flags: approval-mozilla-aurora?
Attachment #8406220 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [good first verify]
Flags: in-testsuite?
Flags: in-testsuite? → in-testsuite-
Flags: in-qa-testsuite?
See Also: → 1230846
You need to log in before you can comment on or make changes to this bug.