Call to ToLowerCase() seems to be expensive.

VERIFIED DUPLICATE of bug 96529

Status

()

VERIFIED DUPLICATE of bug 96529
17 years ago
17 years ago

People

(Reporter: harishd, Assigned: ftang)

Tracking

({perf})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Sample quantify run loading about:blank.

Function:
nsCharsetAlias2::GetPreferred
Calls:
        414
Function time:	38.83 usec (0.00% of Focus)
F+D time:	840,726.55 usec (0.06% of Focus)
Avg F time:	0.09 usec
Min F time:	0.09 usec
Max F time:	0.18 usec
Module:
y:\mozilla\dist\WIN32_O.OBJ\bin\components\uconv.dll
Source File:	y:\mozilla\intl\uconv\src\nsCharsetAliasImp.cpp
Measurement:
Line
Hidden functions:	(None)

source:
NS_IMETHODIMP nsCharsetAlias2::GetPreferred(const nsString& aAlias, nsString&
oResult)				
{
  nsAutoString aKey;
  aAlias.ToLowerCase(aKey);

Comment 1

17 years ago
ftang: can we remove the ToLowCase()?  What are the implications?

=== assigning to ftang and cc'ing yokoyama ==============
Assignee: yokoyama → ftang
Summary: Call to ToLowerCase() seems to be expensive. → Call to ToLowerCase() seems to be expensive.

Updated

17 years ago
Keywords: perf
(Assignee)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 96529 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified as such. Please reopen in case someone diagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.