Closed Bug 982334 Opened 6 years ago Closed 4 years ago

Disable unused-local-typedefs warnings

Categories

(Firefox Build System :: General, defect, trivial)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1117259

People

(Reporter: zwol, Assigned: zwol)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

A trunk build right now produces 152 unused local typedef warnings, all of which are junk, because several of our embedded third party libraries use local typedefs as a fallback for static_assert, and (apparently) it never comes up otherwise.
Attachment #8389446 - Flags: review?(gps)
In case anyone is curious, here is the output of "mach warnings-list | grep unused-local-typedefs" for one of my local debug builds.
Assignee: nobody → zackw
Status: NEW → ASSIGNED
fwiw we explicitly decided not to do this in bug 851237.

If we want these warnings to go away it seems like it would be better to either disable them per directory, or better yet patch the projects to use static assert when building as c++11 or add attributes if compiling with gcc / clang.
Comment on attachment 8389446 [details] [diff] [review]
no-unused-local-typedef-warnings.diff

Review of attachment 8389446 [details] [diff] [review]:
-----------------------------------------------------------------

Comment #2 implies this patch is not desired.

Also, for changes to C++ warnings, I think tbsaunde or ehsan should look at patches like this before they get to a build peer.
Attachment #8389446 - Flags: review?(gps)
Ehsan suppressed -Wunused-local-typedef warnings in bug 1117259.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117259
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.